DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!

View Poll Results: Was this helpful?

Voters
2. You may not vote on this poll
  • Yes

    2 100.00%
  • No

    0 0%
Results 1 to 6 of 6

Thread: Input Method Notification Removal (no root)

  1. Junior Droid
    dale.j.gilbert's Avatar
    Member #
    231968
    Join Date
    Oct 2011
    Posts
    24
    Phone
    bionic
    #1

    Post Input Method Notification Removal (no root)

    This may be old news to a lot of people but I've had trouble finding how to remove the annoying notification that pops up every time you go to type something in ICS or JB. I finally found a way online that worked without rooting so I figured I'd post it so maybe someone ells looking could find it easier, and see how to do it. I know you could do it with root and delete the keyboards all together, but for a non-tech person or someone who does not want to risk bricking their phone, this is a much safer alternative.

    (This is for the Droid Bionic, but it should work similarly for any Android device
    )
    0. You DON'T need to be rooted to do this.
    The "Disable" function is part of Android, it does not delete the app. Disable can also be used to turn off bloatware apps if your squeamish about rooting to get rid of them. It does however stop the app from working at all, so be sure that its not used or connected to any of the apps you use. Unlike using root and Titanium Backup to delete or "freeze" an app, Disabling will not keep you from being able to take any updates. When the update checks the app will still be there, just turned off

    1. System Settings-->Language & Input
    Go down to the Keyboard & Input Methods section and uncheck everything but the keyboard that you plan to use, including "Google voice typing" and "moto Chinese input" (for me that means leaving Swiftkey checked). having only one checked should stop the notification. However on the Bionic there are two input methods that the checkmark is blocked out on so you can't uncheck them: the stock keyboard and Swype. These two are what would keep the stupid notification coming back. So you need to go turn the things off manually in apps.

    2. System Settings-->Apps-->All-->Android Keyboard (AOSP)-->Disable-->OK
    System Settings-->Apps-->All-->Swype-->Disable-->OK
    As far I know disabling these shouldn't mess with any other apps on your phone if you have another keyboard installed from the market, so don't worry about the notification that pops up when you hit "Disable".If you are worried about it...then you'll have to live with the notification. If something down the road does cause you a problem and you think this is it then just go back to apps-->all, scroll all the way down, and hit "Enable", then reboot and you should be good to go. If you use one of these two instead of a third party keyboard I'm sure you could just disable the other one and get the notification to go away.

    3. Power off and reboot your device.

    4. Open up texting and test that when you select the input field A) you don't get a notification and B) That a keyboard shows up at all
    If you don't get a keyboard at all don't panic, there's just one more step to do.If you still get a notification go back to step one and make sure that any other keyboards are unchecked.

    5. System Settings-->Language & Input-->Default-->Select your keyboard (for me this is Swiftkey)
    Your keyboard of choice should be the only option in this list, select it and then go test to make sure everything works right.




    Hope this helps someone!
    Last edited by dale.j.gilbert; 04-20-2013 at 09:05 PM.
  2.  
     
     
     
  3. Droid Newbie
    Snazzytime's Avatar
    Member #
    346363
    Join Date
    May 2013
    Posts
    1
    Phone
    Galaxy Nexus
    #2
    Oh my god I have been looking for this solution for so long and so many people have said to just deal with it or that nothing can be done. This works perfectly. Thank you so much for posting this wonderful solution.

    You're amazing.
  4. Droid Newbie
    Maxdout38's Avatar
    Member #
    348004
    Join Date
    Jun 2013
    Posts
    2
    Phone
    Samsung Galaxy S3
    #3

    Not solved for Me.....

    I recently purchased a Galaxy S3 and have an issue. I love Swiftkey and want to use it on this new phone as my keyboard choice.

    I noticed however, that I constantly get asked for an input method on this phone.

    I select Swiftkey and cannot unselect Sansung Keyboad, because it's blocked out.

    I was able to unselect the Swpe Keyboard and then I 'disabled' this keyboard under the Application settings.

    That Swype keyboard is no longer there as a choice.

    Anyone have an answer on how I can use my Swiftkey keyboard and stop the annoyiing "Enter Input Method"?



    Thanks



    Maxdout38
  5. Super Moderator
    FoxKat's Avatar
    Member #
    54290
    Join Date
    Apr 2010
    Location
    Pennsylvania
    Posts
    8,588
    Liked
    2291 times
    Phone
    DROID MAXX XT1080!
    Premium Member
    #4
    I thought that once you've selected Swype, the only "Enter Input Method" notification you receive is in the status bar. This is the way it works on my Razr MAXX. It's easy to ignore that tiny icon popping up in the status bar for me, isn't it for you? Unless S3 handles this process differently and you get an on-screen notification, in which case I don't know.

    "Professor FoxKat"
    "Saving DROID Razr's, one battery at a time. :-)" - (credit SallyC)
    Avatar is Maxwell Smart, AKA Agent 86, from "Get Smart" (with his signature "Shoe Phone"), a SitCom TV series by Mel Brooks & Buck Henry, based on the spy thriller series, "The Man From U.N.C.L.E.".
    "Guidelines of Conduct" for DroidForums.net
  6. Droid Newbie
    Maxdout38's Avatar
    Member #
    348004
    Join Date
    Jun 2013
    Posts
    2
    Phone
    Samsung Galaxy S3
    #5
    Quote Originally Posted by FoxKat View Post
    I thought that once you've selected Swype, the only "Enter Input Method" notification you receive is in the status bar. This is the way it works on my Razr MAXX. It's easy to ignore that tiny icon popping up in the status bar for me, isn't it for you? Unless S3 handles this process differently and you get an on-screen notification, in which case I don't know.
    It's in the status bar, but very annoying.....
  7. Nice Guy
    aaf709's Avatar
    Member #
    6126
    Join Date
    Nov 2009
    Location
    So Cal
    Posts
    4,181
    Liked
    127 times
    Phone
    Samsung Galaxy S4
    Premium Member
    #6
    Is that what that means? I just thought it meant that the keyboard was active and ignored it.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. select input method notification
    By dale.j.gilbert in forum Droid Bionic Tech Support
    Replies: 7
    Last Post: 11-03-2012, 03:46 PM
  2. select input method
    By lju64 in forum Droid RAZR Support
    Replies: 11
    Last Post: 09-15-2012, 06:22 PM
  3. Replies: 10
    Last Post: 08-10-2012, 07:02 AM
  4. "Select Input Method" Notification??
    By the_krusatyr in forum Droid Razr and Razr Maxx ICS discussion
    Replies: 10
    Last Post: 07-03-2012, 03:30 PM
  5. Text Input Method
    By Detonation in forum Android General Discussions
    Replies: 15
    Last Post: 09-30-2010, 10:30 PM

Search tags for this page

android choose input method
,

choose input method

,
choose input method android
,
choose input method galaxy s3
,

choose input method notification

,
disable select input method notification
,
galaxy s3 choose input method
,

how to get rid of select input method notification

,
htc one choose input method
,
samsung galaxy s3 choose input method
Click on a term to search our site for related topics.
Find us on Google+