Google earth and instagram, along with some other random apps, have a banner saying "your device is not compatible with this version." Is anyone else getting this? It worked when i was on 232, just curious why it would be different on 246.