DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Page 1 of 4 1 2 3 ... LastLast
Results 1 to 10 of 38

Thread: Corporate Sync -- Cannot connect to server

  1. Junior Droid
    snootalope's Avatar
    Member #
    210715
    Join Date
    Jul 2011
    Posts
    9
    Phone
    Droid2
    #1

    Corporate Sync -- Cannot connect to server

    Our business got our first Droid3 today, and it's not been good. Everything on the phone is awesome, other than the fact the corporate sync doesn't work.

    We've got a million Droid2's hooked up to our Exchange 2010 server and I've never once had an issue with them syncing.

    Setting up the Droid3 is just like setting up the Droid2 as far as the corporate sync goes, however once entering the mail server manually and hitting next to establish the connection, it immediately says "Error. Could not connect to the server" and that's as far as I get.

    I spent the morning on the phone with tech support and the data application developers or whoever they are beyond basic tech support and they said there is a known issue with the Droid3 and the corporate sync and they're working on a service pack or an update. No timeline on the update, nothing beyond "they're working on it."

    How in the %&$# do you release a smartphone when you KNOW it has a bug and can't sync with Exchange 2010 and enhanced security.
    Last edited by snootalope; 07-12-2011 at 01:50 PM.
  2. Junior Droid
    snootalope's Avatar
    Member #
    210715
    Join Date
    Jul 2011
    Posts
    9
    Phone
    Droid2
    #2
    Just an update, incase anyone else runs into this which I'm guessing there'll be plenty.

    I found this post: Exchange activesync problem with Android 2.3.3. - Google Mobile Help

    Apparently this has been a known issue for quite sometime and goes back to 2.3.3. It was supposed to be fixed apparently in 2.3.4, but I it's been confirmed that its definitely not fixed.

    I've loved the Droid's for years now. But, this is the first BS move I've seen them make and it's a HUGE deal breaker.
  3. Senior Droid
    mattbooty's Avatar
    Member #
    165733
    Join Date
    Jan 2011
    Posts
    112
    Phone
    Droid 3
    #3
    I'm guessing this must have something to do with the settings on your exchange server or possibly your SSL certificate (if your exchange box is requiring one). My activesync is working fine. I did read elsewhere that the D3 no longer allows you to "accept all certificates", which would then break your connection if you are using a self-signed cert. Otherwise its possible that a specific active-sync policy on your exchange box is blocking access or the droid doesn't like.

    I can help compare active sync policy settings with what I'm running if you need assistance.
    Last edited by mattbooty; 07-13-2011 at 08:04 AM.
  4. Junior Droid
    snootalope's Avatar
    Member #
    210715
    Join Date
    Jul 2011
    Posts
    9
    Phone
    Droid2
    #4
    another update. A work around on this is to setup the account while connected to the local LAN of the exchange server and disable the secure connection, or open up 80 to your exchange server on your firewall. Setup the account, then manage the account, and disable certificate checking.
  5. Junior Droid
    snootalope's Avatar
    Member #
    210715
    Join Date
    Jul 2011
    Posts
    9
    Phone
    Droid2
    #5
    It's definitely a certificate issue. However, since they removed the option to just accept all certificates its complicated things.
  6. Junior Droid
    aconway's Avatar
    Member #
    151415
    Join Date
    Dec 2010
    Posts
    15
    Phone
    Droid A855
    #6
    I use Touchdown Exchange.. it's infinitely better than the built in mail app for Exchange Servers... it has a feature to "fetch and trust certificate", which is very useful... although, in a perfect world, you shouldn't have to use it if your cert is set up correctly.. .. but yeah, dealing with cert issues is probably the #1 pain for remote Exchange connectivity... I hear ya. It's $20, with a 1 month full demo, BTW and no I don't work for them, I just really like the app!
  7. Senior Droid
    mattbooty's Avatar
    Member #
    165733
    Join Date
    Jan 2011
    Posts
    112
    Phone
    Droid 3
    #7
    Quote Originally Posted by aconway View Post
    I use Touchdown Exchange.. it's infinitely better than the built in mail app for Exchange Servers... it has a feature to "fetch and trust certificate", which is very useful... although, in a perfect world, you shouldn't have to use it if your cert is set up correctly.. .. but yeah, dealing with cert issues is probably the #1 pain for remote Exchange connectivity... I hear ya. It's $20, with a 1 month full demo, BTW and no I don't work for them, I just really like the app!
    I liked touchdown better than the OG droid exchange client, but if you haven't already give the D3 exchange client a try, i like it a lot.
  8. Senior Droid
    mattbooty's Avatar
    Member #
    165733
    Join Date
    Jan 2011
    Posts
    112
    Phone
    Droid 3
    #8
    Quote Originally Posted by snootalope View Post
    It's definitely a certificate issue. However, since they removed the option to just accept all certificates its complicated things.
    Are you using a self-signed cert or is it a paid cert?

    I agree, I'm not sure why they removed that option, we have a paid cert on ours so it works fine, but I know a lot of companies don't want to shell out $50 a year when you can self-sign one for free.
  9. Droid
    ocdtrekkie's Avatar
    Member #
    108650
    Join Date
    Aug 2010
    Posts
    46
    Phone
    Droid
    #9
    I'm also having trouble with my DROID3 Corporate Sync. We have DROID2s that work, and our mail server uses a self-signed certificate.
  10. Junior Droid
    goober0122's Avatar
    Member #
    157490
    Join Date
    Jan 2011
    Posts
    12
    Phone
    Motorola Droid 3
    #10
    I had this same exact issue with my Droid 3 yesterday. Corporate Sync worked for a few days and then I couldn't connect. I made the mistake of deleting the account, turns out our SSL cert expired yesterday. On the other Droid 3s I was able to disable certificate verification under the account settings and they worked fine. Mine was not able to re-create the account. The cert was renewed this morning and all is well in the world. If you are using a self-signed cert you will need to either have your Droid 3 on the lan when creating the account or get a paid cert.
Page 1 of 4 1 2 3 ... LastLast

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. connect droid to ft server over 3g
    By painball64 in forum Android Applications
    Replies: 3
    Last Post: 04-27-2011, 11:26 AM
  2. Replies: 11
    Last Post: 08-20-2010, 05:56 AM
  3. Struggling to connect to my exchange server
    By JmoFinD in forum Android General Discussions
    Replies: 2
    Last Post: 07-15-2010, 01:08 PM
  4. Can't connect to Google server
    By fgonzo98 in forum Rescue Squad Help
    Replies: 5
    Last Post: 05-11-2010, 02:05 PM
  5. Could not connect to server, will retry shortly
    By czerdrill in forum Android General Discussions
    Replies: 0
    Last Post: 04-29-2010, 05:36 PM

Search tags for this page

android exchange cannot connect to server

,
corporate sync server
,
couldn't open connection to server due to an invalid server
,
droid 4 exchange could not connect to server
,
droid can't connect to server
,
droid razr unable to connect to server
,

droid x2 cannot connect to exchange

,

droid x2 cannot connect to server

,

droid x2 could not connect to server

,

enter your existing corporate sync account

Click on a term to search our site for related topics.
Find us on Google+