On that note do all of you have the smart feature enabled?? If so have you tried disabling it to see what happens??