DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 6 of 6

Thread: ADB does not find device

  1. Droid
    PCRoger's Avatar
    Member #
    115790
    Join Date
    Sep 2010
    Posts
    47
    Phone
    Droid X
    #1

    ADB does not find device

    Ok, I had it working once, used the screen capture program.

    Now if I try running ddms.bat, it says 'adb start-server' failure

    If I run adb devices, I get "error: protocol fault (no status)"

    I have the Motorola Droid X 4.6.0 drivers and it shows up in Device Manager. I can explore the SD card with no problem,

    Debugging is On, phone is in "PC Mode"

    Help?

    thanks.
  2. Rescue Squad
    Sydman's Avatar
    Member #
    90551
    Join Date
    Jul 2010
    Location
    Austin, Tx
    Posts
    3,406
    Liked
    698 times
    Phone
    Nexus 5
    Premium Member
    #2
    If it was just not seeing your phone it would just say devices and be blank. Not sure what that error you are getting means. Try switching your phone from pc mode to media sync mode.
  3. Droid
    PCRoger's Avatar
    Member #
    115790
    Join Date
    Sep 2010
    Posts
    47
    Phone
    Droid X
    #3
    Quote Originally Posted by Sydman View Post
    If it was just not seeing your phone it would just say devices and be blank. Not sure what that error you are getting means. Try switching your phone from pc mode to media sync mode.
    Tried that, Windows showed the device installed for use and all that.

    Same error message from ADB devices command.

    thanks.
  4. Rescue Squad
    Sydman's Avatar
    Member #
    90551
    Join Date
    Jul 2010
    Location
    Austin, Tx
    Posts
    3,406
    Liked
    698 times
    Phone
    Nexus 5
    Premium Member
    #4
    You already tried uninstalling adb and putting it back. You running as administrator right? What OS you runnnig?
  5. Droid
    PCRoger's Avatar
    Member #
    115790
    Join Date
    Sep 2010
    Posts
    47
    Phone
    Droid X
    #5
    Quote Originally Posted by Sydman View Post
    You already tried uninstalling adb and putting it back. You running as administrator right? What OS you runnnig?
    Yes, reinstalled ADB.

    Windows XP as administrator
  6. Rescue Squad
    Sydman's Avatar
    Member #
    90551
    Join Date
    Jul 2010
    Location
    Austin, Tx
    Posts
    3,406
    Liked
    698 times
    Phone
    Nexus 5
    Premium Member
    #6
    This is from another user on a different post. Maybe try that


    Lots of pages here that I haven't read all of them to see if someone mentioned this, but I had a similar but different problem. At one point I bricked the thing, sbf would not flash whatsoever (tried multiple sbfs). Eventually RSDlite said it was done, but the phone still said "SW Update in progress". After trying to reboot the only thing I could get was "Code Corrupt". Flashing or anything else wouldn't work at all. The way I fixed it (tried 3x to make sure it worked perfectly...i bricked a lot lol):

    Open the folder RSDlite is in, and delete any files that start with a date and end in flexlog, ie "09_14_22_10_21_FlexLog". Then delete any files that start with Flasherrorlog, like "FlashErrorLog09_14_22_10_21".
    Uninstall the moto drivers via the install/uninstall exe
    Uninstall RSDlite via the install/uninstall exe
    You can restart your computer at this point if you want but I'm not sure its necessary
    Reinstall moto drivers
    Reinstall RSDlite, and don't forget to copy over the pst_flash file
    Go into bootloader mode and flash the_gift w/ RSDlite. This can take ~15 minutes from clicking start to phone being rebooted

    I'm not sure if all those steps are 100% necessary, but that's what definitely worked for me. If you're stuck and out of other options, give it a try.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Multimedia audio to a Bluetooth speaker device? Cant find a solution...
    By PCweber in forum Android General Discussions
    Replies: 10
    Last Post: 06-15-2013, 05:55 AM
  2. usb device not recognized
    By poxine in forum Android Tech Support
    Replies: 8
    Last Post: 07-12-2010, 12:55 PM
  3. how do I find my Droid's device security code
    By jack t in forum Android Tech Support
    Replies: 2
    Last Post: 06-03-2010, 01:51 PM
  4. same app on different device
    By Big Ry in forum Android Applications
    Replies: 0
    Last Post: 03-19-2010, 08:49 AM
  5. How many of you will root their device?
    By Quickster357 in forum Android Hacks and Help
    Replies: 35
    Last Post: 12-22-2009, 07:22 PM

Search tags for this page

adb device not showing up
,
adb devices not listed
,
adb devices not showing
,
adb devices not showing device
,

adb devices not working

,

adb not detecting device

,

adb not seeing device

,
adb not showing devices
,
device not showing adb devices
,
device not showing up in adb
Click on a term to search our site for related topics.
Find us on Google+