I am running Liberty GB V0.8. I've never had problems with any Google download. I recently noted an update for Google Search. It downloaded but would not deploy. The error message is "Package file was not signed correctly."

Any thoughts?

Jim