DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 9 of 9

Thread: Can't connect to my home router since GB update... NO WIFI!!!

  1. Droid Newbie
    purplkoolaid's Avatar
    Member #
    202091
    Join Date
    Jun 2011
    Location
    Ventura, CA
    Posts
    2
    Phone
    Droid X
    #1

    Unhappy Can't connect to my home router since GB update... NO WIFI!!!

    Hope somebody can steer me in the right direction... Since the .596 OTA update I have not been able to fully connect to my router (Belkin N1). My DX will identify the router/signal, but can't obtain an IP address. I've reset my router 2x already, and I have been able connect to another router. Any suggestions? Thanks!
  2.  
     
     
     
  3. Junior Droid
    sinkSlacker's Avatar
    Member #
    202903
    Join Date
    Jun 2011
    Posts
    6
    Phone
    Motorola Droid X
    #2

    WPA revives Droid X Wifi killed by Gingerbread

    After updating my Droid X to gingerbread (Android version 2.3.3) using the over-the-air (OTA) update, I was unable to connect to the internet through my wifi router (Netgear WNR2000). The Droid X connected to the wifi router without a problem, but would not connect to (fetch anything from) the internet.

    I found that changing the security on my wifi router from WPA2 to WPA fixed the problem.

    Note that before changing the security on my wifi router, I also tried a few other things that did not work, including: resetting the cable modem, router, and Droid X several times; disabling MMS in the router; setting the router to broadcast the SSID; changing the router's channel from Auto to 2. I reverted to the initial setting after each attempt.
  4. Master Droid
    kevinkar's Avatar
    Member #
    121054
    Join Date
    Sep 2010
    Posts
    300
    Liked
    1 times
    Phone
    Droid X
    #3
    No matter what, it seems that Motorola or Android developers do not know how to save wireless settings from one OS update to the next and this has vexed me twice on previous updates but thankfully not on GB. Yet.

    All I can say is that you SHOULD NOT change WPA2 to WPA to "fix" this issue. Or at least you shouldn't have to. One should strive to make things MORE secure, not LESS secure.

    One thing you can try is to check what your router is sending, N-only, G-only, or Mixed. Try changing it from Mixed to N only or G only or from N or G only to mixed. That worked for me. If you are at N only but change to G only, it won't really affect the connection speed to your phone. It's worth a try. But you certainly should not have to downgrade your security settings to connect.

    If nothing works, you might need to perform a factory reset on the phone but that's a last resort.
  5. Junior Droid
    sinkSlacker's Avatar
    Member #
    202903
    Join Date
    Jun 2011
    Posts
    6
    Phone
    Motorola Droid X
    #4
    Correction: Keep WPA2 and decrease router's max speed to revive Droid X wifi killed by Gingerbread

    Thanks kevinkar--you're right.

    I decreased the "mode" setting on my Netgear WNR2000 wifi router to "Up to 54 Mbps" and increased the router security to WPA2. My Droid X is running great on wifi.

    I was hesitant to decrease the max router speed to 54 Mbps until I realized that the max download speed on my Comcast Xfinity connection is less than that: 50 Mbps (speedtest.net tests average around 20Mbps with my laptop). So I'm probably not losing any speed with the new setting.

    I'm assuming that "Up to 54 Mbps" is G (the router manager GUI doesn't refer to anything in terms of B, G, N). I used to have it set to "Up to 145 Mbps", which I assume is N. The only other choice is "Up to 300 Mbps"--I don't know what that might be. Thanks again.
  6. Master Droid
    kevinkar's Avatar
    Member #
    121054
    Join Date
    Sep 2010
    Posts
    300
    Liked
    1 times
    Phone
    Droid X
    #5
    Quote Originally Posted by sinkSlacker View Post
    I was hesitant to decrease the max router speed to 54 Mbps until I realized that the max download speed on my Comcast Xfinity connection is less than that: 50 Mbps (speedtest.net tests average around 20Mbps with my laptop). So I'm probably not losing any speed with the new setting. I'm assuming that "Up to 54 Mbps" is G
    Yeah, this is correct. I'm willing to bet your router is still faster than the internet connection on both G and N so using G speeds only (54Mbps) is not going to do a thing.

    Now, if you were transferring a file from PC to your phone and your router and phone supported N speeds, that would be slower if you limited it to G only. However, internet access is limited to your service speed and that's bound to be less than what the router provides in G mode.
  7. Droid Newbie
    Airportlounge's Avatar
    Member #
    214134
    Join Date
    Jul 2011
    Posts
    1
    Phone
    Motorola Atrix
    #6

    Can't Connect to Belkin Wifi Router after Gingerbread Update

    I have exactly the same issue. Since I updated my Atrix to Gingerbread I cannot connect to my Belkin N1 wifi router. I have factory reset my phone, updated the router firmware and tested virtually every setting on the router (all Channel and SSID variables and all Security options) and nothing works. Any other ideas? Thanks
  8. Master Droid
    kevinkar's Avatar
    Member #
    121054
    Join Date
    Sep 2010
    Posts
    300
    Liked
    1 times
    Phone
    Droid X
    #7
    Try setting your router to G only. Then turn OFF any security. Also make sure your SSID is NOT hidden. Once you've done that, unplug the router's power. Then unplug your cable modem's power. Wait about 30 seconds and then plug in the modem and wait for it to boot up. Then, once it's up and running, plug in the router's power and wait for it to completely boot up.

    If you don't have it, I recommend grabbing Wifi Analyzer from the Market and installing it.

    Then, turn on your phone's wifi, go into the Wireless settings and "forget" any networks you may have previously set up. Then, when they are all blank, go into Wifi Analyzer and see if it even sees your router's wireless (it should show the SSID, signal strength, etc.) If so, go back into the wireless settings and try to connect to your network. It SHOULD work now.

    Assuming you DID connect, go into your router and change to N-only (2.4Ghz since that's what the phone uses, not 5Ghz), don't hide the SSID, and turn off security. Note - I recommend naming the G radio something like AirportloungeG and the N radio AirportloungeN so you can distinguish between them. If your router is simultaneous dual band, I still recommend trying the two radios separately and one at a time before enabling both at the same time.

    At this point, you should also see the N network and be able to connect.

    If by now you've been able to connect to two unhidden unsecured networks, you can then turn on security to one (you can try them from weakest to strongest - WEP, WPA, WPA2) and see if you can connect to them. You should be able to. Oh, and make sure, if you get to WPA2 and your router has a setting for it, use AES only and not AES-TKIP. There seems to be a consensus to not use TKIP for some reason.

    After all that, try setting your radio to Mixed (G and N) to see if you can still connect.

    It's a pain but the only way you can find out where it fails.

    Let us know if any of this helped.
  9. Droid Newbie
    sasankasb's Avatar
    Member #
    345038
    Join Date
    May 2013
    Posts
    1
    Phone
    Samsung Galaxy S Advance i9070
    #8
    Add the Mac Address of your phone in your modem settings.
    Mac Address of the phone can be found in Settings->About Phone->Status->Wi-Fi Mac Address

    Access the modem settings page.
    Go to Configurations->Wireless Settings->Mac Address Filter tab or link.
    Add the Mac address from the Phone

    Thanks
    Sasanka
  10. Banned
    june87's Avatar
    Member #
    347324
    Join Date
    Jun 2013
    Posts
    8
    Phone
    Enter Current Phone Model Here
    #9
    I am a bit confused, so all other computers can connect to the router, only the phone can not connect?

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Droid X won't connect to home WiFi
    By SammyQ2 in forum Android Tech Support
    Replies: 7
    Last Post: 08-12-2013, 09:24 PM
  2. Unable to Connect to my Router
    By LeftSnow in forum Android Tech Support
    Replies: 2
    Last Post: 03-28-2011, 10:46 AM
  3. need help can a Droid 1 connect to a router
    By helinut in forum Android Hacks and Help
    Replies: 23
    Last Post: 01-12-2011, 03:38 PM
  4. Replies: 19
    Last Post: 01-04-2011, 01:38 PM
  5. Connect a Droid 2 to a wireless router
    By pjbodie in forum Motorola Droid 2
    Replies: 18
    Last Post: 11-19-2010, 07:13 AM

Search tags for this page

android galaxy captivate can only connect to wireless that i
,

android gingerbread and belkin router wifi problems

,

can phone connect to router

,

cant connect to my xfinity thur my router

,
comcast wireless router security android
,

galaxy s2 not connecting to xfinity router

,

gingerbread+does+not+connect+to+n router

,

need help connecting my s3 to wnr2000 wireless router

,

s4 cant connect with my router

,
why wont my phone connect to belkin router
Click on a term to search our site for related topics.

Tags for this Thread

Find us on Google+