DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 1 of 1

Thread: AOSP roms USB issues

  1. Developer
    devortex's Avatar
    Member #
    103336
    Join Date
    Aug 2010
    Posts
    352
    Liked
    6 times
    Twitter
    devvortex
    Phone
    Galaxy Nexus (CDMA)
    DroidForums.net Developer
    #1

    AOSP roms USB issues

    Hello smart people.

    I have a quick question that has been stumping me for quite some time.

    When I use Apex rom or Fission, and connect my X to my computer, all usb settings work (media sync, pc mode, storage, and charge). Also via adb I can do adb remount and/or adb root. When I run adb shell, I immediately get the # prompt meaning I'm running with root access.

    Whenever I try using a more aosp rom, like Jrummy, Rubix or others, PC mode and Media sync end up breaking on MTP Device driver install so media sync is useless. Also adb remount fails and adb root gives an error that root is not allowed on a production build.

    I've checked build.prop to see if I can see anything out of the ordinary on these roms, but besides memory tweaks and things they are very close to the apex build.prop file.

    Is there somewhere else I should look where the rom determines if it's a production build? Are these two issues related? Does anyone else observe this? I know there was a thread in the rubix section where doing some kind of recovery reboot fixes the mtp device error, but that never worked for me, and there were mixed reports.

    Thanks.

    Walking on water and developing software from a specification are easy if both are frozen
    ~ Edward V Berard
  2.  
     
     
     

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Custom Ringtone Issue on AOSP-ish Roms
    By JRobzilla in forum Droid X Roms
    Replies: 0
    Last Post: 12-29-2010, 08:28 AM
  2. FAQ: Updates/Roms/Issues
    By mcp770 in forum Drod2169 - X
    Replies: 0
    Last Post: 12-27-2010, 11:16 AM
  3. Battery issues with Kennedyx Roms ):
    By fr3nzy in forum Droid X Roms
    Replies: 9
    Last Post: 11-06-2010, 01:38 PM
  4. FRG22D ROMs and intermittent flash issues
    By Mbk in forum Android Roms
    Replies: 12
    Last Post: 09-06-2010, 10:42 AM
  5. Issues with ROMs
    By khrisdeus in forum Android Tech Support
    Replies: 27
    Last Post: 08-09-2010, 12:41 AM

Search tags for this page

android production build change build.prop
,
aosp mtp
,
aosp mtp driver
,

aosp usb driver

,
cyanogen mtp
,
milestone cyonegen mtp usb
,

milestone mtp usb driver

,
milestone mtp usb problem
,
motorola mtp usb device installation failed cyanogenmod
,
usb drivers aosp
Click on a term to search our site for related topics.

Tags for this Thread

Find us on Google+