Okay, this is a strange one. So it started off with me wanting to update my phone to the latest update; i sbf'd it (since i was on rubix 1.9 non-leak) and then updated through OTA. I then made a mistake by flashing rubix 1.9 (non-leak) and that ended up with me having a boot loop. I then went into stock boot recovery and then wiped cache and then data in preparation to sbf it, but after i hit reboot, it booted up normally! I was at the "welcome to android screen", but then i realized that having the non-leak version of rubix on 2.2.34 might create issues. So what i wanted to ask is can i use the sbf that brings me back to 2.15 or am i stuck until a new one comes out? My bootloader says 30.04, so im guessing i cant use that one...