Hi,

I have a Droid X and I get terrible reception at work. I average about -100dBm signal strength, but yet still have ~2 bars for 3g. When I get close to my window, I get about -80dBm and maybe like 3 to 4 bars.

I figured I would try the Wilson MobilePro antenna, since many people rave about it. 200 bucks is a little hard to swallow now, so I went to buy it on eBay for less than half that.

At home, it worked OK. I could see a difference, but nothing happened other than I'm glad I didn't spend 200 bucks on it. The LED was green and it looked like things were working fine at home.

At work, it's a different story. I have a hard time trying to tell the difference between red and amber, so I don't know what's going on with it. It's rare that the unit turns green, and the light will go red/amber frequently. Sometimes permanently, sometimes it will flicker and go green, but then back to red.

There's little difference with the phone and the signal, and it seems like it's not even working. (The wilson unit that is). I've tried numerous locations around my office with the antenna and the amp portion, and it seems rare that the light turns green. I have the little rubber duckie antenna with the magnetic mount. I tried the antenna on the windowsill, different windows, up top having it magnetically stuck to the blinds, and they all yield the same results.

I know this isn't a wilson help forum per say, but lots of people here use these, and I don't know where else to go. Any suggestions woudl be helpful!

thanks!