DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 5 of 5

Thread: Exchange Server Corporate Email Won't Set Up on Razr M

  1. Droid Newbie
    Droidstein's Avatar
    Member #
    315718
    Join Date
    Dec 2012
    Posts
    2
    Phone
    razr m
    #1

    Exchange Server Corporate Email Won't Set Up on Razr M



    5 people in my IT dept cannot figure out why exchange server email setup is not working on my new Razr m (4.1.1). Settings have been triple checked and I still get "can't connect to server" error message. Other employee's Razr HD works fine, same settings as I am trying to use. gmail works fine. Love this phone—battery life is amazing, screen sharp as get-out and small size is perfect for me. But if I can't get work emails to load, it's going back to the store. ugh.
  2.  
     
     
     
  3. Master Droid
    jackiescivic's Avatar
    Member #
    169639
    Join Date
    Feb 2011
    Location
    Muskego, WI
    Posts
    881
    Liked
    244 times
    Phone
    Maxx, Maxx HD, Razr Maxx
    #2
    Try using a 3rd party app like MailDroid or K9. I have had problems getting my business email to connect and have not had a problem since switching to MailDroid.
  4. Droid Newbie
    Droidstein's Avatar
    Member #
    315718
    Join Date
    Dec 2012
    Posts
    2
    Phone
    razr m
    #3

    Fix Found

    The default port when setting up exchange server email was 443. I Googled this problem and found that some people were having success changing the port number to 80. Tried that and it worked like a charm. IT dept apparently hasn't yet heard of Google...unbelievable.

    Hope this helps.
  5. Rescue Squad
    Sydman's Avatar
    Member #
    90551
    Join Date
    Jul 2010
    Location
    Austin, Tx
    Posts
    3,406
    Liked
    698 times
    Phone
    Nexus 5
    Premium Member
    #4
    I know you already got the stock APP fixed but if you find it does not meet your needs I would recommend trying Touchdown. I have it setup for my personal work email and out technical support box and it manages both extremely well.

    The paid APP is 20 bucks but well worth it if you find the default one lacking.
  6. Droid Newbie
    Iacovos's Avatar
    Member #
    350845
    Join Date
    Jul 2013
    Posts
    1
    Phone
    Nexus 4
    #5
    Quote Originally Posted by Droidstein View Post
    The default port when setting up exchange server email was 443. I Googled this problem and found that some people were having success changing the port number to 80. Tried that and it worked like a charm. IT dept apparently hasn't yet heard of Google...unbelievable.

    Hope this helps.
    Confirm - changing port from 443 to 80 did the trick for me! Thank you so much for this.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Do you have to pay the corporate email fee to access an Exchange server?
    By PaulQ in forum Android General Discussions
    Replies: 2
    Last Post: 02-18-2012, 08:25 PM
  2. Replies: 2
    Last Post: 11-16-2011, 06:31 AM
  3. Replies: 0
    Last Post: 10-26-2011, 11:23 AM
  4. Replies: 2
    Last Post: 09-23-2011, 01:47 PM
  5. Exchange server email
    By nathan56989 in forum UltimateDroid
    Replies: 4
    Last Post: 04-06-2011, 07:00 AM

Search tags for this page

android exchange email cannot connect to server
,
at&t email exchange servers port numbers for droid
,

can't setup exchange on android

,
cant connect to server, corporate email droid
,
connect to corporate email on a droid maxx hd
,
droid maxx can't connect to exchange
,
droid razr can't setup corporate account
,
droid razr exchange email setup
,
droid razr wont connect to email server
,

setting up corporate email on droid razr m

Click on a term to search our site for related topics.
Find us on Google+