Hi,

I have DROID RAZR with Android ICS version. In an idle mode, I have disabled sound for incoming messages, emails and notifications. When I'm talking on the phone incoming messages are making a loud noise which makes my ears blow out. It is really frustrating while talking on the phone (I get too many messages daily and all those are corporate sms messages) and I couldn't figure out how to disable the audio for incoming message while talking.

The phone doesn't make a notification sound but it is in the background while talking that I get this noise.

Please help !!!