hope im posting in right area, and thanks in advance..so , i had bionic on page plus everything working even data though just 1x, but just could not send pictures but that was ok. i then acepted a software update which appears to be the jellybean. on phone information it says system version 98.72.22.xt875, for android version it says 4.1.2. the problem now is that i see the data symbol 3g or 1x on the upper left corner, but the symbol is clear as opposed to solid blue like before, needles to say that i can not log in to internet . also, the only way the 3g symbol will show up is if i have wifi turned on, the second i turn off wifi, 3g symbol disappears even if i have mobile data turned on. is this due to the new software? i ried programming phone using dfs cdma tool, updated prl, set up data, nam as per instructions on other posts but still no data. sid, nid, all seems to be correct. i tried in cdma only, cdma and auto prl, cdma evdo, but no data. any ideas, suggestions, information wil be greatly appreciated. i been at this for days. i do get voice, and text, just no data. thanks again.