Some background about the phone:
I purchased it on eBay about 3 weeks ago. Received it in the mail, and the phone worked perfectly except for the well-known earpiece problem. It worked, but was barely audible. I noticed the problem after rooting the phone and installing safestrap 3.11 successfully. (also loaded a ROM successfully into Slot 1 in safestrap) The phone was stock when I received it. (JB OTA)
After noticing the problem with the earpiece, I decided to check and see if by any chance the phone was still under manufacturer warranty, and to my relief, it was! (under warranty until March 2014)

OK, so now I had to prep the phone for return to Motorola. Deleted the ROM in Slot 1. Uninstalled safestrap recovery 3.11 inside stock ROM (JB OTA), and then removed the APK. Used a utility from the xda forum to return to stock using fastboot. The name of the utility is this: (DROID_4_Utility_Jellybean_XT894_WinMacLin) This util is great, and has worked flawlessly for me on all of my Droid 4s. (this is my fourth D4... so I do have some experience with this phone when it comes to flashing etc)

The phone restored perfectly, and I sent it out to Motorola. I just got it back in the mail yesterday. I will take that as proof that my attempt to return to stock worked, as they did not reject the warranty claim etc. (they did a great job btw, and were very fast and helpful throughout)
So I got my phone back, and it is time to re-root and get safestrap going again. I have no problem rooting or installing busybox on the stock ROM at all. My next step was to install safestrap, so I decided to go for the newest version. (3.53) The recovery installed perfectly, but when I tapped on "reboot into recovery", I got a SuperUser FC right before the phone rebooted. The phone did reboot with no problem, and safestrap was indeed installed. I enter the recovery, and try to create a new ROM slot in Rom Slot 1.

This is where I get the error.
Can't mount /osh.

I tried to just ignore the error, and install a ROM. Everytime I try to flash, I get the same error about mounting /osh.

After seeing the errors, I decide to try and SBF one more time, to no avail.

When I look at the receipt from Motorola, the listed Repair Action is "Reprogramming/Reflash/MR/MC". I found that to be odd, bc I had thought that there was a problem with the hardware.. (earpiece) They do not mention replacing hardware of any kind in the BOM.

Here's my question finally... Is it possible that Motorola just re-flashed the phone with a newer build that fixes a glitch with the earpiece? There is no evidence at all of the phone being opened. (believe me I know. I have rebuilt these things before)
I am assuming that I am having trouble with safestrap bc Motorola re-flashed the device. ANY freedback would be appreciated. I have recovery log files if you are interested. Thanks in advance I know this is a very long post!