Recently I just switched from a Droid 1 to 4 and had problems setting up my Juno email account as it was not communicating with the Juno server. After 6 hours of tech support, Juno tech support came through with the solution.

Their incoming server setting port should be: 110, and the outgoing port setting should be 587. Their website lists other settings.

Also you need to go to your computer and check the following and this will solve the entire problem.

1. Sign in to your Juno Email on the Web at webmail.juno.com
2. Click on "Options" and select "General," or click on "Settings" and select "POP Mail" under "Preferences"
3. Select "ON - POP my mail to my desktop/smartphone"
4. Click "Save" to finish

Be sure your Juno email's server settings are:
POP: pop.juno.com
SMTP: smtp.juno.com

Hope this helps others in the future. Enjoy.