DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 4 of 4

Thread: Droid4 Not sending or receiving data (or intermittant) when connected to Wi-Fi (3G)

  1. Droid
    NiteCloak's Avatar
    Member #
    251332
    Join Date
    Feb 2012
    Location
    Michigan
    Posts
    41
    Liked
    1 times
    Phone
    Droid 4
    #1

    Thumbs up Droid4 Not sending or receiving data (or intermittant) when connected to Wi-Fi (3G)

    Background

    I was the first person (at my local Verizon Store) to obtain the new Droid 4 last Friday (10th) and was delighted with it to begin with. I had been waiting for this phone for a very long time, and had passed over my upgrade eligibility several times over 6 months in the process.

    The first day I was excited to enjoy the lightning fast speeds of 4GLTE and the phone was everything I hoped it would be. I could argue the point over the fact that there are a lot of unnecessary pre-installed apps that cannot be uninstalled (without rooting/jail-breaking the phone) but the fact remains that I got what I was looking for, a 'Razr' style phone with an excellent, tactile, precise, slide-out 5-row keyboard.

    Issue

    Unfortunately for me, I may work in a 4G neighborhood but I live in a 3G neighborhood and at best I can usually hope to see little more than 2 bars on my signal strength meter for 3G at my abode. Naturally I planned to access my home Wi-Fi, Comcast Cable served by my trusty Netgear 802.11b/g Router.

    This is where the problems began. As soon as the phone detected the Wi-Fi and connected (you see the 3G logo go from blue to white in the status bar and the Wi-Fi symbol appear, then go from white to blue) I suddenly noticed that the phone refused to send or receive any data whatsoever. Phone and texting functionality remain solid, but any data related application was failing. Email (Gmail app) , Market app, streaming music or videos, in fact anything at all that required data.

    Naturally my frustration grew. Lets face it, what earthly use is a smartphone on an unlimited data plan if I can't even send or receive an email with it!
    After two extremely long phone calls (2+hours) with Level 2 Verizon Tech Support (out of Arizona) we were able to narrow it down to the Wi-Fi component of the phone, but no resolution. I replaced the phone with another the following morning but the same problem persisted. Leave the phone in 4G/LTE or 3G modes and data transfer is fine, allow the phone to auto switch in to Wi-Fi (or manually place it there) and I was getting nothing.

    Verizon tech support argued that with the phone being so new, and me being one of the first adopters, there was no existing knowledge-base of problems/solutions from which they could draw (my second tech support rep even cited that they used online blogs and forums such as this to assist in their calls). Its nice to be a guinea pig!

    Finally, out of sheer frustration and at the recommendation of the last Verizon Tech Support contact, I called Motorola directly and after some frustration getting past the less-than-capable Tier-1 support person, I eventually got put through to a pleasant guy, a level 2 tech support specialist in Boca Raton in FL. We spent the best part of 2 hours on the phone and finally figured out the solution.

    Solution

    The solution is two things:

    1. Firstly a phone setting needs to be changed. There is a setting that was set to on by default and (for me at least) needed to be turned off. This setting is called ENABLE AUTO IP and effectively creates a conflict with what my router was trying to assign it automatically via DHCP.

    i) Go to Menu (menu softkey)
    ii) Choose 'Settings'
    iii) Select 'Wireless & Networks'
    iv) Select 'Wi-Fi Settings'
    v) Press the menu softkey again and select 'Advanced'
    vi) Uncheck the checkbox called 'Enable Auto IP'

    2. Secondly, come to find out that the new Droid4 does NOT like to play nicely with WEP encryption. This was amazing to me seeing as I have 7 other devices that all work perfectly with WEP encryption on my router, including two iPhone 4S's. So I switched to WPA2 encryption and low and behold, the phone is a go!


    Total hours spent on finding a resolution: 11.5 hours.



    NiteCloak
    Last edited by NiteCloak; 02-14-2012 at 11:18 AM.
  2. Droid
    diablo85's Avatar
    Member #
    251237
    Join Date
    Feb 2012
    Posts
    35
    Liked
    1 times
    Phone
    Droid 4
    #2
    glad to hear you got it sorted out. also happy to hear you switched over to a more secure wireless security protocol.
  3. Droid Newbie
    antdan's Avatar
    Member #
    253086
    Join Date
    Feb 2012
    Posts
    1
    Phone
    Enter Current Phone Model Here
    #3
    Very glad you posted this, I hope it works for me. How do you switch to WPA2?

    I was at a tech conference (oh the irony) yesterday and this same problem arose for me. For half a day I struggled with logging in and out of the hotel wifi but being completely stymied... i was supposed to be tweeting for my company during the conference but could not use any form of data... no email, no web, no social media.... I finally called verizon tech support as a last resort and the woman very matter of factly told me "oh yeah, if you have any signal on your phone you have to turn off wifi/data or else nothing works." I was like what on earth are you talking about, that's insane! I had a droid x for the previous 2 years and never had this issue. She was like " I don't know about your past phone but when using droids, MORE OFTEN THAN NOT, you must turn off wifi if you have any bars on your phone signal" (emphasis mine). Sure enough, disable wifi and all was well.. except then what's the friggin point of the data plan!!!??? And what about those times when you have 1 measly bar and sending an email takes 5 minutes...

    SO, clearly they have been encountering this issue with numerous people and have come up with this simple, yet completely insane workaround. Just disable wifi! Madness.

    I was worried when I got one of the first droid 4's that I would suffer the fate of the early adopter and it appears that I am indeed suffering such a fate.... dammit all to hell!!
  4. Droid
    NiteCloak's Avatar
    Member #
    251332
    Join Date
    Feb 2012
    Location
    Michigan
    Posts
    41
    Liked
    1 times
    Phone
    Droid 4
    #4
    WPA2 encryption is done at the router end, through it's firmware interface (usually accessed through the LAN on your web browser) but honestly, for me that was an added issue of my Droid4 not wanting to play nicely with WEP.

    The real issue on the phone was the ENABLE AUTO IP check box needing to be unchecked. Try that first.

    Good luck.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Preventing data cut-off when sending/receiving text messages
    By mewshi in forum Droid 2 Tech Issues
    Replies: 0
    Last Post: 12-02-2010, 10:03 AM
  2. Not receiving or sending texts
    By gcushenb in forum LG Ally
    Replies: 0
    Last Post: 09-03-2010, 09:49 PM
  3. MMS not sending or receiving
    By allikanbe in forum Android Tech Support
    Replies: 5
    Last Post: 06-20-2010, 09:02 PM
  4. Sending and receiving pdf files?
    By jamjr74 in forum Android General Discussions
    Replies: 1
    Last Post: 04-06-2010, 11:35 AM
  5. GMail not sending or receiving
    By zfly9 in forum Android Tech Support
    Replies: 18
    Last Post: 03-09-2010, 12:10 PM

Search tags for this page

android can't connect to comcast wifi
,
android phone not receiving data
,
android problem receiving data
,
data not working on droid 4
,

droid 4 data not working

,
droid 4 not getting 3g
,
droid problem receiving data
,
droid x2 data not working
,

droid x2 no data connection

,
droid x2 not getting data
Click on a term to search our site for related topics.
Find us on Google+