DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 7 of 7

Thread: How to unbrick a "dead" Milestone

  1. Junior Droid
    andoruB's Avatar
    Member #
    227708
    Join Date
    Oct 2011
    Posts
    25
    Phone
    Motorola Milestone
    #1

    How to unbrick a "dead" Milestone

    After an unfortunate rooting session with my Motorola Milestone, the phone now returns into an "dead" mode. It refuses to start at all. I tried charging it and see if it starts by itself, but it doesn't budge and the little while led doesn't lit. The only time when it lit is when I connect it to the PC. I tried putting in it a new battery, taking out the SD card and SIM, but to no avail. I remember seeing a video where a guy used a dissected USB cable to spark the phone into turning on again, so I take it I'll have to use a "hardware approach"? Please help.
  2.  
     
     
     
  3. Master Droid
    googlelover's Avatar
    Member #
    84373
    Join Date
    Jul 2010
    Location
    California
    Posts
    355
    Liked
    6 times
    Phone
    Motorola Droid
    #2
    Try going to XDA, they seem to have gotten the milestone following, droidforums is more for the Verizon Droid. Not trying to be mean at all, just you'll probably get better help there then here.
    Running SS5.6/Cushzero 2.3.7
    Loving the Gingerbread deliciousness
    O/C 1.1 Ghz Chevy low voltage kernal.
  4. Junior Droid
    andoruB's Avatar
    Member #
    227708
    Join Date
    Oct 2011
    Posts
    25
    Phone
    Motorola Milestone
    #3
    That's ruled out already, I tried there too. Though there's not much difference between the two phones other than the network they use.
  5. Junior Droid
    andoruB's Avatar
    Member #
    227708
    Join Date
    Oct 2011
    Posts
    25
    Phone
    Motorola Milestone
    #4
    I tried following this guide, though without success. The phone still has that white LED lit when it's connected to the PC.
  6. Junior Droid
    andoruB's Avatar
    Member #
    227708
    Join Date
    Oct 2011
    Posts
    25
    Phone
    Motorola Milestone
    #5
    *bump* Anyone?
  7. Droid Newbie
    charlesfg's Avatar
    Member #
    259810
    Join Date
    Apr 2012
    Posts
    1
    Phone
    motorola milestone 2
    #6
    Dude...
    Any update?

    I have the same issue!
  8. Junior Droid
    andoruB's Avatar
    Member #
    227708
    Join Date
    Oct 2011
    Posts
    25
    Phone
    Motorola Milestone
    #7
    Apparently after I left it for over a month with the battery pulled out it worked again (though that time I tried it with a mains charger) and it worked again, but the battery became wonky so I bought another one. I have no idea what happened or what to suggest you to do, sorry X.X

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Eris (yes "ewwww") dead screen spots...
    By Shiano in forum Rescue Squad Help
    Replies: 2
    Last Post: 07-26-2011, 08:00 PM
  2. "Critical Error DEA1" - Dead Flash Chip?
    By maxzutter in forum Droid X Tech Support
    Replies: 0
    Last Post: 06-03-2011, 05:58 PM
  3. Replies: 3
    Last Post: 07-11-2010, 01:35 PM
  4. "False" dead battery issue?
    By Ghostwheel in forum Android General Discussions
    Replies: 24
    Last Post: 07-07-2010, 02:35 PM
  5. Replies: 5
    Last Post: 02-12-2010, 07:49 AM

Search tags for this page

how to unbrick droid x

,
how to unbrick droid x2
,

how to unbrick motorola milestone

,
milestone 2 critical error dea1
,

milestone 2 dead

,

motorola milestone dead

,
motorola milestone x2 dead
,

unbrick milestone

,

unbrick milestone 2

,
unbrick milestone x2
Click on a term to search our site for related topics.
Find us on Google+