Quote Originally Posted by acidcore View Post
I was going through a ton of forums and threads and I figured out why blake. When you edit images and save them they have to be the same "weight" as the ones you are replacing. So basically it is the graphics not being the correct "weight" and when you upload that framework it is seen as invalid and will just kill your phone. I have stopped trying to make my own framework-res.apk for now and am just looking for already made ones. Best of luck to you if you keep trying blake.
Quote Originally Posted by Drukan View Post
For those of you attempting to create/edit your own theme work.... METAMORPH is what you need.
its avail in the marketplace. a few searches on it here and at AllDroid will give you all the info you need.
I have modded my icons and there's been no thought to "weight" and all icons have been direct replacements for already existing stock icons, or those that come with the ROM I'm running. Keep that in line and you should be fine...

Quote Originally Posted by acidcore View Post
Quote Originally Posted by bb-gun View Post
Quote Originally Posted by acidcore View Post
Thanks drukan but you don't need metamorph I figured out what I was doing wrong my files just didn't coincide with what the droid expected so it crashed once I figured out how to change the graphics so the droid accepted them it works fine. I've edited every app in my phone now lol.
Do you have to use adb to push them? or can you use root explorer to copy and paste them from your sd card to your phone?
to put them on my phone i do this. first i put the .apk onto my sdcard then i do this in command prompt.

adb shell
su
mount -o rw,remount /dev/block/mtdblock4 /system
dd if=/sdcard/*.apk of=/system/*/*.apk

* = name of apk and the directory of where it is located on the droids file system.
Hopes this helps!
After much asking and searching the above solution has worked every time! The only thing that I fail to see being mentioned (which makes me think that it doesn't happen to everyone) is that you have to put back in your Gmail and facebook account info. Also, the terminal emulator code that I put in is a bit different than above, so this will give you another option, again, this is using Terminal Emulator available from the Market. After you put the framework-res.apk on your root directory of your sdcard::

su
mount -o rw,remount /dev/block/mtdblock4 /system
busybox cp -R /sdcard/framework-res.apk /system/framework
reboot

Again, this has worked for me every time and I've done it probably 12 times in the last few days tweaking my icons.