Okay, I'm a tehcy nut and a developer and I therefore tend to make electronic devices to unreasonable things. Like installing 11 operating systems on s single hard drive on a laptop. Well, I use my Droid enough that it does become sluggish. I use dxTop with every screen and the slide bar filled. Well, iit was down to nearing just 20 megs of RAM left. My phone's battery, whicyh I had neglected to recharge, began to die. AndroidOS did it's duty and began to try and shut down my phone. It froze trying to do this. I then brought it upstairs and plugged it. The charge light won't light up but it's not running on 0% battery power for an hour. I even checked the settings and it still says 0% discharging. Also, I had to take it out of airplane mode. It seems when shutting down it does this. I pulled the plug out and it tried it again. It froze again. I opened up Advanced Task Manager Free which was in my notification bar and killed dxTop. Just openeing that got me away fromthe shutting down notification. So, when I pushed the home button, it started it up again. It's been acting strange too. A long press on the home button still yields my recent apps... or rather a nonupdated recent apps. The back button doesn't work right... just gives me a black screen. I have to press home to do anything. The settings button on the home screen still works. I tried killing all sorts of processes to reset something so it realizes it's plugged in. I'm seeinjg how long it'll let me get away with this.