I was suddenly unable to access my internal storage (to copy photos, for example) and I found the fix/workaround. (new Droid user, btw)

Check the box: Settings > Connect to PC > Ask me
and set as DISK DRIVE by default

Without checking the box, it will only read the SD card.

I've confirmed this on Linux Ubuntu 10.04, and haven't tried the workaround on Windows 7 yet.