DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 1 of 1

Thread: Droid Razr - USB Mode doesn't work (have tried multiple solutions)& How to Back Up?

  1. Droid Newbie
    sketysh's Avatar
    Member #
    322195
    Join Date
    Jan 2013
    Posts
    1
    Phone
    Droid Razr
    #1

    Droid Razr - USB Mode doesn't work (have tried multiple solutions)& How to Back Up?

    I've had my Motorola Droid Razr for about a year. I ordered it online around the time it first came out.
    I've only ever had one problem with it which occurred about 4-6 months after owning my phone.
    My USB mode doesn't work on my phone.
    I've just lived with taking my SD card out manually or using MotoCast to DL files from my PC.

    I've tried:
    •Different cables(all stock cables from friends)
    •Different computers(WinXP and Win7)
    •Turning my computer off and on
    •Re-installing Windows
    •Turning my Droid Razr off and on
    •Resetting Phone to factory
    •Adjusting the tongue inside my phones USB port

    And maybe one or two that I may have forgotten.

    At this point I'm almost positive it's my phone. I'm going to take it to Verizon and they'll probably give me a refurbished phone or something.
    Is there a way for me to back-up my phone and install everything back on to the refurbished phone exactly how my current phone is set up?

    Thanks for all your help! Much appreciated.
  2.  
     
     
     

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. GB Update, now USB PC Mode doesn't work
    By il padrino in forum Droid X Tech Support
    Replies: 0
    Last Post: 06-02-2011, 01:36 PM
  2. droid 1 back button vibrates but doesn't work
    By dm1027 in forum Android Hacks and Help
    Replies: 1
    Last Post: 03-27-2011, 07:30 PM
  3. Recovery Mode Doesn't Work
    By dh1234567 in forum Droid Incredible Tech Support
    Replies: 9
    Last Post: 12-19-2010, 01:25 PM
  4. Replies: 0
    Last Post: 09-02-2010, 11:37 PM
  5. Upper LED doesn't work while in multimedia mode
    By bcmarauder in forum Bugless
    Replies: 3
    Last Post: 03-26-2010, 04:01 PM

Search tags for this page

droid razr doesn't mount
,
droid razr m came out on what date?
,
droid razr usb
,

droid razr usb mode

,
my droid razor usb dont work on computer
,
razr usb dont work
,
razr usb mode
,
usb mode droid razr
,
why doesn't droid razr charge from usb.
,
why doesn't my android have usb
Click on a term to search our site for related topics.
Find us on Google+