DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 8 of 8

Thread: Droid X won't connect to home WiFi

  1. Junior Droid
    SammyQ2's Avatar
    Member #
    144381
    Join Date
    Dec 2010
    Posts
    28
    Phone
    Droid RAZR MAAX 4GLTE
    #1

    Droid X won't connect to home WiFi

    I have had my Droid X for about three weeks.

    When I first brought my Droid home I was able to connect to my home wireless for about a day. Seemed to work fine.

    Now, it is unable to connect. When I am on the settings page and tap on my WiFi network to Connect, it acts like it's working, then it says "Authenticating", then stops when it says "Disabled, secured with WPA/WPA2 PSK".

    I have tried visiting the Verizon store (no help), wrote directly to Motorola and they said to do a factory reset (no help) and just tried rebooting my home wireless router (no help).

    Any suggestions from this knowledgeable crew?

    Thanks.
  2. Droid
    droiddict's Avatar
    Member #
    7414
    Join Date
    Nov 2009
    Posts
    93
    Phone
    (Droid) Motorola Razr HD
    #2
    Same problem here. I've just been living with no WIFI at home but it is annoying. Everything else, including my dear D1 connects with no problems.
  3. Junior Droid
    SammyQ2's Avatar
    Member #
    144381
    Join Date
    Dec 2010
    Posts
    28
    Phone
    Droid RAZR MAAX 4GLTE
    #3

    Now okay

    I finally got mine going. Not quite sure how I did it though.

    I did get connected at a hotel, then when I came home I could get on.

    Keep trying, I'm glad I did.
  4. Droid
    rosem119's Avatar
    Member #
    107409
    Join Date
    Aug 2010
    Posts
    32
    Phone
    Motorola Droid 2
    #4
    First try this. Go to settings, wireless, wifi settings. Tap your network, tap the Forget button. Then retry the setup.
    If this doesn't work, try changing anything in your router settings, like changing the security from WPA2 to WPA. Save and then change back to WPA2.
    One note--these phones do not like WEP.

    Sent from my DROID2
  5. Droid
    droiddict's Avatar
    Member #
    7414
    Join Date
    Nov 2009
    Posts
    93
    Phone
    (Droid) Motorola Razr HD
    #5
    I did try the forget and reconnect routine one more time after posting and it has worked through a sleep this morning. We'll see if it continues. Searching finds mostly the X with this problem. I suspect in my case, I could fix it with a new router, but as long as everything else that I run connects OK, seems like the X should too.
  6. Droid
    rosem119's Avatar
    Member #
    107409
    Join Date
    Aug 2010
    Posts
    32
    Phone
    Motorola Droid 2
    #6
    I felt the same way but finally gave up and changed the router security knowing I would have to change 2 laptops, a netbook, a Tivo, an iPaq, an iPod Touch and a wireless printer. A pain, but only once.
    Do you also have your phone's wifi sleep policy set to Never? If you don't, every time it sleeps, the wifi will shut off and it will have to reconnect. Putting it on never will save your battery because when it disconnects, it goes searching for the cell signal and that eats the battery. To check or change the sleep policy, go to settings, wireless, wifi settings, menu, advanced, wifi sleep policy. Change to never.
    I had to do both of these things shortly after I got my phone and it has worked fine ever since.
    Sent from my DROID2
  7. Droid Newbie
    thphoenix's Avatar
    Member #
    352607
    Join Date
    Aug 2013
    Posts
    2
    Phone
    Enter Current Phone Model Here
    #7

    Wireless entry gets disabled.

    ok, for such an interesting phone on the shelf, the DroidX certainly has it's problems.

    Can't keep the display on 24-7, otherwise the display dies when it cools down. (first 2 pixel lines only). Already had it replaced once, and due again. sheesh.

    Probably the weirdest thing was my home network was appearing as "Disabled" and I didn't do anything..


    So why?

    Well, Belkin (and some other routers, but belkin mainly) has made a mistake in their DHCP programming. I've stopped trying to get them to fix it because I never get a decent response. Unfortunately, my current favorite Netgear is starting to follow the same path. (Very frustrating)

    First, you must understand how it does the connection. (took quite a while to figure it out.)

    Once it connects, it is assigned an address. your wireless symbol will appear bright white on the strength indicator.

    Next, it will connect to your Google account. When successful, the icon turns blue.
    (took me a long time to figure this one out.)


    So what went wrong? Belkin's DHCP (and some others) will not resend the DHCP response when a device has already been assigned the address
    Why? Windows-based systems will automatically maintain their address if they get no response. (truthfully, they probably never worked with anything but Microsoft devices.)

    So why won't it work?

    If it doesn't receive the IP address, it thinks the security settings are wrong. It will disconnect and try 2 more times.

    After the third try, it will mark it Disabled.


    So how do we fix this? Well, trying to get the attention of people making the cheapest wireless hosting devices on the market doesn't seem to be doing any good.
    Second, I still haven't found an app that can switch to a static IP on specific networks, and the phone doens't support autoswitching correctly either.
    -- Auto IP normally defaults to the static IP created, but because of how the Belking router responds, this fails.

    You need to set a static address in order to use this router.

    If I --EVER-- figure a better way around this, other than replacing the router, I will put it here.

    Good luck, hopefully this helps others.
  8. Droid Newbie
    thphoenix's Avatar
    Member #
    352607
    Join Date
    Aug 2013
    Posts
    2
    Phone
    Enter Current Phone Model Here
    #8

    Found it..

    Found a program that seems to handle it fine..

    WiFi Auto Changer by ForestreeLab..

    Long-click on your router, then check the box..

    Finally, I don't have to remember to change the silly thing.. Now I hope I can find it for Kindle.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Droid X Wifi conection won't connect to the Web?
    By k1hog in forum Droid X Tech Support
    Replies: 0
    Last Post: 11-21-2010, 06:22 AM
  2. Way to connect Droid to Ad-Hoc Wifi?
    By skater8705 in forum Android Hacks and Help
    Replies: 10
    Last Post: 09-14-2010, 11:24 PM
  3. Droid X wifi connection crashing home wifi network. help!
    By bluflax in forum Droid X Tech Support
    Replies: 7
    Last Post: 08-15-2010, 09:26 PM
  4. Allow iPhone wifi connect my Droid
    By FoFa in forum Android General Discussions
    Replies: 3
    Last Post: 04-08-2010, 09:55 AM
  5. Can find droid wifi tether, but cannot connect
    By orthrwi in forum Android Hacks and Help
    Replies: 2
    Last Post: 01-07-2010, 07:24 AM

Search tags for this page

droid won't connect to wi-fi
,
droid won't connect to wifi
,
droid x won't connect to wifi
,
droid x won't connect to wifi network
,
droid x wont connect to home wifi
,

droid x wont connect to wifi

,
droid x2 wifi network disabled
,
my droid wont connect to wifi
,
why won't my droid x connect to wifi
,

why wont my droid x connect to wifi

Click on a term to search our site for related topics.

Tags for this Thread

Find us on Google+