I've spent the good part of a day trying to install the ADT on the latest version of eclipse that's available on Debian Squeeze (that is, Eclipse 3.5 -- Galileo). After adding the "https://dl-ssl.google.com/android/eclipse/" site to the Eclipse repository, along with "http://download.eclipse.org/releases/galileo", I tried to install:

* Android DDMS
* Android Development Tools
* Android Hierarchy Viewer
* Android Traceview

and got:
Code:
Cannot complete the install because of a conflicting dependency.
  Software being installed: Android Traceview 21.0.0.v201210310015-519525 (com.android.ide.eclipse.traceview.feature.group 21.0.0.v201210310015-519525)
  Software currently installed: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
  Only one of the following can be installed at once: 
    OSGi System Bundle 3.5.2.R35x_v20100126 (org.eclipse.osgi 3.5.2.R35x_v20100126)
    OSGi System Bundle 3.5.1.R35x_v20090827 (org.eclipse.osgi 3.5.1.R35x_v20090827)
    OSGi System Bundle 3.5.1.R35x_v20090806 (org.eclipse.osgi 3.5.1.R35x_v20090806)
    OSGi System Bundle 3.7.2.v20120110-1415 (org.eclipse.osgi 3.7.2.v20120110-1415)
    OSGi System Bundle 3.5.0.v20090520 (org.eclipse.osgi 3.5.0.v20090520)
    OSGi System Bundle 3.5.2.R35x_v20100105 (org.eclipse.osgi 3.5.2.R35x_v20100105)
  Cannot satisfy dependency:
    From: Eclipse Platform 3.5.2 (Eclipse Platform 3.5.2)
    To: org.eclipse.osgi [3.5.2.R35x_v20100126]
  Cannot satisfy dependency:
    From: Android Traceview 21.0.0.v201210310015-519525 (com.android.ide.eclipse.traceview.feature.group 21.0.0.v201210310015-519525)
    To: org.eclipse.core.runtime 3.6.0
  Cannot satisfy dependency:
    From: Core Runtime 3.7.0.v20110110 (org.eclipse.core.runtime 3.7.0.v20110110)
    To: bundle org.eclipse.osgi [3.7.0,4.0.0)
It seems Eclipse is trying to install 3.6 components to a 3.5 installation. Where can I get an ADT for Galileo?