DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 4 of 4

Thread: PLEASE HELP...issues after unrooting!!!

  1. Master Droid
    jbg25's Avatar
    Member #
    22021
    Join Date
    Jan 2010
    Posts
    560
    Liked
    1 times
    Phone
    Rezound
    #1

    PLEASE HELP...issues after unrooting!!!

    Hey guys...sorry this is going to be so long...but I think the more info I give you the more likely you will be able to identify my problem and help me fix it.

    A little backstory.....
    A few weeks ago I was trying to get help unrooting my droid. I was having problems with the rom that I loaded (following these instructions....http://androidforums.com/how-tips/29204-how-root-install-droid-2-1-a.html).

    This was several weeks ago, and I had used droidroot helper v4 and at the time the OP had posted the files including tar to drop in the nandroid backup folder that gave me HCs old 2.1 rom w/o su. It was very buggy for me and I wanted to uninstall/swap with another rom. But no matter what i tried (found many instructions using SPR, adb, shell or a combo of the three) I kept getting errors along the way that prevented me from doing anything.

    Then I found Speedymons uninstall instructions on alldroid.org. But I got errors every time I tried to restore to the virginoem file. The error I kept getting was... "status 25".

    So I PM'd SirPsycho and developer of Droidroot helper over at alldroid.org, but never heard back. I have since found out the site was hacked...so I waited almost 2 weeks, then posted this issue over there...but although a had 2 dozen people read...no one had any thoughts.


    back to the isse at hand....
    So I had to go elsewhere and hope someone could help me unroot. At the suggestion of the person who posted the rooting method...I tried doing it through downloading the Eclair_2.0.1 file and renaming to udate.zip and dropped on SD card to install, and got more errors. This time the errors were..

    Assert failed: apply_patch_check("/system/app/alarmClock.apk", "36fa8c6f8036e4bed36056c1797c4ee40f746b3c","fa ce49 02c83611a0e55c8640dc95133ebe2c5fla")
    E:Error in /sdcard/update.zip
    (status 7)
    Installation aborted.

    So, I spent a few hours doing a lot of reading and experimenting with adb and shell...and finally got back to oem...BUT I AM POSITIVE I LEFT SOMETHING OUT AND FEAR IT WILL CAUSE PROBLEMS!

    The following quote is from my post in the tread posted above that describes how I did it.

    I have been asked to relay to the best of my ability how to get back to 2.0.1 OEM if you are also having problems using the methods provided in OP.

    I will do my best...but it was very much my experimenting around. I was praying the whole time I did not do something unrepairable.

    First and most important is that I can only say that this works for sure from 2.0.1 w su.

    The reason is that before I upgraded to 2.1 I did an advanced nandroid backup of 2.0.1 w/su. None of my attempts to restore from 2.1 worked. I always ended up with a blank version of 2.1...ALTHOUGH...now that I think about it considering how I ended up reseting... it could work from anywhere I guess.

    So first I restored to 2.0.1su (may or may not be necessary)

    I downloaded DroidBR (placed both on sd card as suggested)

    I mounted Droid to PC and opened adbshell typed SU then flashed recovery image (flash_image recovery /sdcard/recovery.img)

    I was unable to flash the boot.img...said I did not have permission...which is wierd no?

    I rebooted into recovery anyway and got the OEM recvoery menu. So I figured I was close.

    I tried to install the original 2.0.1 updat.zip we all used to update manually back in Nov...but got some error. So I tried a factory reset. This worked...I saw the unpacking image and then had phone reboot to the original set up menu (had to contact verizon and press 1 to program phone). Skip set up!

    This put me back to 2.0.1 OEM but still had su and busybox. From here I mounted the phone again used the ADB Shell Commands I found in this post to remove su and busybox...

    http://www.droidforums.net/forum/dro...sybox-etc.html

    (if using adb shell, don't forget to put phone in USB debugging mode)
    su
    mount -o remount,rw -t yaffs2 /dev/block/mtdblock4 /system
    rm /system/bin/busybox
    rm /system/xbin/busybox
    rm /system/app/Superuser.apk
    mv /system/recovery-from-boot.old /system/recovery-from-boot.p

    after than I did one more factory reset...and VOILA!

    Disclaimer....I am nothing near a programmer or developer. And I cannot guarantee that there are not still issues that I have not resolved from this. I cannot be held responsible if this does not work or worse.

    Here is the issue, I have had some bugs now that I never experienced before. Random call outs, random shutoffs that require me to pull the battery to restart, more f/c's than I rememeber with the unfinished HC2.1 rom or the oem 2.0.1 before I started adding roms.

    So I read that I could reinstal the 2.0.1 update manually which would clear any potential issues hidning in the OS, using the original 2.0.1 update posted on sholes.info. But I still get erros and the install aborts...and am VERY VERY afraid this will prevent the 2.1 update whenever it does go out.

    If anyone is still reading this...first THANK YOU...second any idea what I have done or what I can do to fix?

    Thanks!!!!
  2.  
     
     
     
  3. Droid Ninja
    Bear in NM's Avatar
    Member #
    3690
    Join Date
    Nov 2009
    Posts
    1,389
    Liked
    5 times
    Phone
    Bionic (sad but sweet)
    #2
    Not sure if this is a solution you could apply, but it appears that some Verizon Stores have the ability to reflash the phone. I normally would not suggest to someone who has "played" with their phone to run to VZW for a fix, but as you phone is not bricked perhaps they could reset you correctly. If it were me, I would find a store that has the ability. If they press for a reason, explain that you added some programs that may be causing some issues, and offer to pay for their time.

    This is just a wag, but if someone here finds a solution, and your phone appears to be running correctly, I am betting in the back of your mind your gonna still be wondering? If so, see my first paragraph. And as you now only have the factory recovery, about the only thing you could try is perhaps downloading a different stock 2.0.1 to confirm that you do not have a bad file, but I guess is that you do not. I would not get too wild and crazy at this point, as you still have a working phone.

    From you error message it would appear that the 2.0.1 you are trying to apply is indeed finding a file mismatch and aborting. I don't know if this is just a normal error trying to install 2.0.1 over 2.0.1 when it expects 2.0 or what. The other thing right now is that we do not know whether the 2.1 is gonna have problems with all of the phones like your's that have been unrooted. Perhaps no problem. One thing for certain is that once 2.1 comes out, this place is gonna be busy if there are any problems. I would just not accept any 2.1 ota's, and check back here to see how things are going once 2.1 is out.

    Craig

    Edit:

    Check out this thread or over at Alldroid. Looks like a maintenance relaease of 2.0.1 may be out and this may clarify your situation. One person reported it broke his root, which could mean good news for you.
    http://www.droidforums.net/forum/dro...e-morning.html
    Last edited by Bear in NM; 01-19-2010 at 11:42 AM. Reason: update
  4. Master Droid
    forkup's Avatar
    Member #
    184
    Join Date
    Oct 2009
    Posts
    317
  5. Master Droid
    jbg25's Avatar
    Member #
    22021
    Join Date
    Jan 2010
    Posts
    560
    Liked
    1 times
    Phone
    Rezound
    #4
    I have a thread over on alldroid where I have been getting some help...now things are worse. before when I had recovery I tried to load the virgin oem....but kept getting errors.

    Having tired that and failed I re rooted my phone in an attempt to get SPR back to load a virgin backup a different way.

    Now the issue is in forcing the phone out of root and back to stock last time I must have unintentionally changed something I was not supposed to. I have no reboot recovery at all. I can boot the phone to use it...I can mount it to my PC...I can even issue commands in ADB and in shell.

    Now every time I try to boot into recovery...I get the moto logo.

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. help! problems unrooting!
    By curiouskyle16 in forum Android Hacks and Help
    Replies: 8
    Last Post: 01-12-2010, 04:58 PM
  2. Need some help with a few issues
    By PacerSS in forum Android Tech Support
    Replies: 6
    Last Post: 01-04-2010, 11:53 PM
  3. Unrooting
    By gilbertorbea in forum Android Hacks and Help
    Replies: 5
    Last Post: 01-03-2010, 10:43 AM
  4. Unrooting
    By jasonwood81 in forum Android Hacks and Help
    Replies: 4
    Last Post: 12-27-2009, 09:30 PM
  5. A Few issues....
    By thefalloftroy in forum Android General Discussions
    Replies: 3
    Last Post: 11-19-2009, 02:39 PM

Search tags for this page

after unrooting reset over and over

,

dm updater

,

remove sir psycho

,

removing sir psycho update

,

sirpsycho droid factory reset

Click on a term to search our site for related topics.
Find us on Google+