DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Results 1 to 10 of 10

Thread: sort of unique problem with droid after attempted flash image installation?

  1. Senior Droid
    boristhebladexx's Avatar
    Member #
    9199
    Join Date
    Nov 2009
    Location
    Connecticut
    Posts
    116
    Phone
    Motorola Droid
    #1

    sort of unique problem with droid after attempted flash image installation?

    ok so i have a problem that i have not been able to find anywhere else on this site.

    i was attempting to install the SP/sholes recovery image so i could install 2.1, but something did not quite go right. because adb wasn't working for me, i used terminal emulator to enter the commands, and now when i hold x at power up, i get the /!\, but when i press the volume up and camera button, it no longer goes to the boot screen thing that it did before when i rooted the phone.

    at first i was freaked out, but i realized that everything still works perfect and no other aspects of my droid were harmed.

    so after swearing off doing anything to my phone, i saw the 'noob guide' to installing 2.1, so i installed droidroothelper and followed the steps, but mounting mtdblock3 or 4 does not work for me, and it just freezes, and i think it has something to do with the attempted flash_image installation.

    so in conclusion, does anyone have any idea what i did to my phone, and if it's fixable?

    thanks in advance
  2. Master Droid
    Berzerker's Avatar
    Member #
    18177
    Join Date
    Dec 2009
    Posts
    331
    Liked
    1 times
    Twitter
    @berzerker7
    Phone
    Motorola Droid Bionic
    #2
    Quote Originally Posted by boristhebladexx View Post
    ok so i have a problem that i have not been able to find anywhere else on this site.

    i was attempting to install the SP/sholes recovery image so i could install 2.1, but something did not quite go right. because adb wasn't working for me, i used terminal emulator to enter the commands, and now when i hold x at power up, i get the /!\, but when i press the volume up and camera button, it no longer goes to the boot screen thing that it did before when i rooted the phone.

    at first i was freaked out, but i realized that everything still works perfect and no other aspects of my droid were harmed.

    so after swearing off doing anything to my phone, i saw the 'noob guide' to installing 2.1, so i installed droidroothelper and followed the steps, but mounting mtdblock3 or 4 does not work for me, and it just freezes, and i think it has something to do with the attempted flash_image installation.

    so in conclusion, does anyone have any idea what i did to my phone, and if it's fixable?

    thanks in advance
    You might want to try waiting a couple seconds then make sure you're pushing the volume up/camera buttons pretty well, I remember it took me a few tries to get it to recognize the button pushes. Once you install sprecovery, the button sequence is not needed as it automatically loads the selection menu.
  3. Senior Droid
    boristhebladexx's Avatar
    Member #
    9199
    Join Date
    Nov 2009
    Location
    Connecticut
    Posts
    116
    Phone
    Motorola Droid
    #3
    i was under the impression that after i installed the sprecovery that it would load a different picture instead of the /!\, and that didn't happen.

    also, is it possible that i could've disabled the default recovery, but failed to install the sprecovery, which is now denying me access to the menu that i would normally get upon holding x at bootup?
  4. Droid Newbie
    SLiKoNe27's Avatar
    Member #
    22779
    Join Date
    Jan 2010
    Posts
    3
    Phone
    Droid
    #4
    Quote Originally Posted by boristhebladexx View Post
    ok so i have a problem that i have not been able to find anywhere else on this site.

    i was attempting to install the SP/sholes recovery image so i could install 2.1, but something did not quite go right. because adb wasn't working for me, i used terminal emulator to enter the commands, and now when i hold x at power up, i get the /!\, but when i press the volume up and camera button, it no longer goes to the boot screen thing that it did before when i rooted the phone.

    at first i was freaked out, but i realized that everything still works perfect and no other aspects of my droid were harmed.

    so after swearing off doing anything to my phone, i saw the 'noob guide' to installing 2.1, so i installed droidroothelper and followed the steps, but mounting mtdblock3 or 4 does not work for me, and it just freezes, and i think it has something to do with the attempted flash_image installation.

    so in conclusion, does anyone have any idea what i did to my phone, and if it's fixable?

    thanks in advance
    did you follow these instructions exactly?
    Installation | Sholes

    It worked for me the first time
  5. Senior Droid
    boristhebladexx's Avatar
    Member #
    9199
    Join Date
    Nov 2009
    Location
    Connecticut
    Posts
    116
    Phone
    Motorola Droid
    #5
    i used instructions on this site, but even if i got those to work, i can't access the screen to load the backup. pushing the camera + volume up buttons doesn't work
  6. Droid Ninja
    Bear in NM's Avatar
    Member #
    3690
    Join Date
    Nov 2009
    Posts
    1,389
    Liked
    5 times
    Phone
    Bionic (sad but sweet)
    #6
    Boris,

    I am not sure this is gonna help, but here goes. I am currently helping another user here sort his phone problems after he got a fouled up system using the root helper ap.

    We figured out last night that while he went through the steps with the root helper, he fuggered something up before he got his new recovery image to stick. If you are still getting the stock recovery triangle like he is, then your flash did not work, or the next step where the recovery-from-boot-image.p gets renamed.

    Not sure if you have a program that will let you see the system files, but you might need one, like Astro to try and troubleshoot. You might want to check on your phone files in /system to see if you have a recovery-from-boot.p If you have this file, in this location, and it is not renamed recovery-from-boot.old or some variation that IS NOT recovery-from-boot.p then you might have a similar problem, a recovery flash without the disabling of the stock recovery program. Also from the person I am helping, he mentioned that the developer of the Root Helper program is pretty responsive to requests for help. Might try that. And, DO NOT RENAME this file if you find it intact, as doing so without first flashing might brick your phone if you try recovery with no recovery image. What I am suggesting is non-fatal ways to trouble shoot.

    I will be helping him shortly on the phone, so I may not be able to follow here, but please check for this file, and if anyone here reading this has gone through the Root Helper Ap, if you could check to see what was done to your recovery-from-boot.p file it might help us help others here who fugger up with the Root helper ap.

    Craig
  7. Senior Droid
    boristhebladexx's Avatar
    Member #
    9199
    Join Date
    Nov 2009
    Location
    Connecticut
    Posts
    116
    Phone
    Motorola Droid
    #7
    i checked in the /system/bin folder, then used astro to search for recovery-from-boot.p but i couldn't find it... possibly deleted?
  8. Droid Newbie
    SLiKoNe27's Avatar
    Member #
    22779
    Join Date
    Jan 2010
    Posts
    3
    Phone
    Droid
    #8
    Quote Originally Posted by boristhebladexx View Post
    i used instructions on this site, but even if i got those to work, i can't access the screen to load the backup. pushing the camera + volume up buttons doesn't work
    try following the instructions on the link I posted. if you do and it works there will be no need to hold the camera and volume button. it will go straight into SPrecovery
  9. Droid Ninja
    Bear in NM's Avatar
    Member #
    3690
    Join Date
    Nov 2009
    Posts
    1,389
    Liked
    5 times
    Phone
    Bionic (sad but sweet)
    #9
    Quote Originally Posted by boristhebladexx View Post
    i checked in the /system/bin folder, then used astro to search for recovery-from-boot.p but i couldn't find it... possibly deleted?
    Boris,

    On a stock phone, this file should be in the /system folder, not the /system/bin. If you are sure this file is no where to be had, this could be a "clew". Unfortunatley this is over my head as to what happens with this file being completely absent, but if you can confirm that this file is nowhere, and you did not get a sprecovery menu, I would suggest staying out of recovery until either perhaps the Roothelper Developer or another here with more knowledge than I can shed some light. Perhaps the flash did not happen correctly, but the next step, renaming or erasing this file happened. Again, I stayed way clear of the Root Helper program, so I do not know if this file was to be renamed or deleted.

    I seemed to recall reading something here on the forum about something like this, describing the boot loading and recovery sequence. Perhaps a seach by "boot loader" might help. Sorry man, trying.

    Craig
  10. Droid Ninja
    Bear in NM's Avatar
    Member #
    3690
    Join Date
    Nov 2009
    Posts
    1,389
    Liked
    5 times
    Phone
    Bionic (sad but sweet)
    #10
    Boris,

    Just an update in case you are still "stuck"

    I went through the Roothelper last night with the user I mentioned, and we were able to get his phone recovered and backed up using the Roothelper. The problem could be the sequence of steps as they are laid out in your Root Helper menu v. the way they should be done while actually doing it. there is a post over on alldroid where one of the users spells out the proper sequence of steps for those who are doing them but do not understand. When i found this post it cleared up for me (not using the program) what could be causing confusion. And, we mounted 4 when we did his phone.

    I also confirmed that the root helper program should only be renaming recovery-from-boot.p to .old, not deleting it. I do not know how this would affect your steps if you attempt a retry with your root helper, but the obvious thing that jumps out at me would be to not use the command to rename the file, if you are truely sure the file does not exist on your phone. My thinking being that if the file does not exist, no sense testing the program logic and programming by attempting a command that will at least return an internal error message in Root Helper.

    Craig

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. FTP image problem
    By Dmoralize in forum Android Tech Support
    Replies: 3
    Last Post: 03-09-2010, 11:27 PM
  2. Problem with flash pictures using Droid camera
    By JessiesGirl in forum Android General Discussions
    Replies: 2
    Last Post: 12-28-2009, 05:03 PM
  3. Problem with image quality after exporting to PC
    By Ineffective in forum Motorola Droid
    Replies: 4
    Last Post: 12-23-2009, 12:14 PM
  4. 2.1 Installation video?
    By xdxdaustinxdxd in forum Android Hacks and Help
    Replies: 3
    Last Post: 12-22-2009, 09:13 PM
  5. Unique Droid homepage
    By haseebrahman7 in forum Android Themes
    Replies: 2
    Last Post: 12-13-2009, 06:05 PM

Search tags for this page

droid camera flash not working
,
how to sort image using flash
,
image error return by camera
,

image error returned by camera

,
recovery from boot.p
,

recovery-from-boot.p

,
recovery-from-boot.p does not exist
,
system/recovery-from-boot.p rename
,
what to do after renaming recovery-from-boot.p
,
where to find recovery-from-boot.p
Click on a term to search our site for related topics.
Find us on Google+