If you're on wireless, you won't have the 3G icon since your data needs are being handled by the wireless instead of via Verizon.

Are you connected via wireless or just have the radio enabled?