Our phone was recently released, how would it be fair to not have 2.1 running for us? Why should we root our droids for 2.1 when they can let us run it as well