DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Page 51 of 108 FirstFirst ... 41495051525361101 ... LastLast
Results 501 to 510 of 1072
Like Tree3Likes

Thread: What have YOU done with Tasker?

  1. Rescue Squad
    Tallica's Avatar
    Member #
    48266
    Join Date
    Mar 2010
    Location
    Middleboro, MA
    Posts
    3,259
    Liked
    6 times
    Twitter
    Tallica21
    Phone
    GSIII-Rooted
    Premium Member
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by Tallica View Post
    Ok Neb, something is up. When I leave my house and my phone disconnects from my network, My Wifi will not turn off unless I do it manually or I leave my "home" area. If i'm connected to cell sites near my house but not close enough to connect to my router I have to shut wifi off manually. After that it seems to work right (turn on screen, wifi scans then turns off when it doesn't connect). What do you think the issue is? I think it might be that the wifi on profile is not going to it's exit task when I'm not near my wifi.
    Make sure you have the latest incarnation of the profile thats on the wiki with the exit task on the wifi near profile.

    If you do then I don't know but I have an idea on how to fix it that I will test tonight
    Think I got the newest, i'll double check and maybe redo the profiles, thanks and i'll be eagerly awaiting your possible fix.
  2. Junior Droid
    Hondo1's Avatar
    Member #
    145362
    Join Date
    Dec 2010
    Posts
    5
    Phone
    HTC Aria
    That depends on how often you are connected to wifi. You could also have it not search for a blue tooth connection when you are home. Or only when you disconnect from the car and home is not set. That would probably be best.

    Profile one
    Context - %HOME = 0
    Context - Disconnected from car's bluetooth specifically.
    Set %BTREADY to 1
    Exit - Set %BTREADY to 0

    Profile 2
    Context - From time (when you wake up) till (when you go to bed) repeat every 5 minutes
    Context - %BTREADY = 1
    Tun Bluetooth On
    wait 30 second
    Turn Bluetooth off if %BLUEC = 0

    Profile 3
    Context - Bluetooth Connected
    Set %BLUEC to 1
    Exit - Set %BLUEC to 0[/QUOTE]

    So I tried this today, but ran into some problems:
    The first profile you suggested above I set up as follows:

    Profile 1
    Context: Not BT Connected (specfically to my car named BT)
    Context: Variable Set: %HOME Value 0
    Task: Variable Set: %BTREADY set to 1
    **You wanted to set up an exit task here, but I'm not given that option. Have I set something up wrong?

    These are the way I set up Profiles 2 and 3. Do they look OK to you?

    Profile 2
    Context:From 0800-2300 repeat every 5 mins
    Context: Variable set %BTREADY Value 1
    Task: Set Bluetooth On
    Task: Wait 30 seconds
    Task: Set Bluetooth Off if %BLUEC matches 0

    Profile 3
    Context: Bluetooth Connected
    Task: Variable Set %BLUEC to 1
    Exit Task: Variable Set %BLUEC to 0
    ** I am unsure of what "[/QUOTE]" means in your profile above**
    Could you explain??

    Obviously, I'm pretty new at this, so your help is *really* appreciated. Thanks.
  3. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Quote Originally Posted by Hondo1 View Post
    That depends on how often you are connected to wifi. You could also have it not search for a blue tooth connection when you are home. Or only when you disconnect from the car and home is not set. That would probably be best.

    Profile one
    Context - %HOME = 0
    Context - Disconnected from car's bluetooth specifically.
    Set %BTREADY to 1
    Exit - Set %BTREADY to 0

    Profile 2
    Context - From time (when you wake up) till (when you go to bed) repeat every 5 minutes
    Context - %BTREADY = 1
    Tun Bluetooth On
    wait 30 second
    Turn Bluetooth off if %BLUEC = 0

    Profile 3
    Context - Bluetooth Connected
    Set %BLUEC to 1
    Exit - Set %BLUEC to 0
    So I tried this today, but ran into some problems:
    The first profile you suggested above I set up as follows:

    Profile 1
    Context: Not BT Connected (specfically to my car named BT)
    Context: Variable Set: %HOME Value 0
    Task: Variable Set: %BTREADY set to 1
    **You wanted to set up an exit task here, but I'm not given that option. Have I set something up wrong?

    These are the way I set up Profiles 2 and 3. Do they look OK to you?

    Profile 2
    Context:From 0800-2300 repeat every 5 mins
    Context: Variable set %BTREADY Value 1
    Task: Set Bluetooth On
    Task: Wait 30 seconds
    Task: Set Bluetooth Off if %BLUEC matches 0

    Profile 3
    Context: Bluetooth Connected
    Task: Variable Set %BLUEC to 1
    Exit Task: Variable Set %BLUEC to 0
    ** I am unsure of what "/QUOTE" means in your profile above**
    Could you explain??

    Obviously, I'm pretty new at this, so your help is *really* appreciated. Thanks.
    The [/QUOTE] was a mistake with the formatting of the forums.

    For profile one don't use the event variable set, use the state variable value, then you can get an exit task. When events trigger they just run through the commands so there is no reason for an exist task. States can exist over time so they can have exit tasks.

    Other than that it looks good.
    Last edited by NebulaOcton; 12-08-2010 at 05:23 AM.
  4. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Quote Originally Posted by Tallica View Post
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by Tallica View Post
    Ok Neb, something is up. When I leave my house and my phone disconnects from my network, My Wifi will not turn off unless I do it manually or I leave my "home" area. If i'm connected to cell sites near my house but not close enough to connect to my router I have to shut wifi off manually. After that it seems to work right (turn on screen, wifi scans then turns off when it doesn't connect). What do you think the issue is? I think it might be that the wifi on profile is not going to it's exit task when I'm not near my wifi.
    Make sure you have the latest incarnation of the profile thats on the wiki with the exit task on the wifi near profile.

    If you do then I don't know but I have an idea on how to fix it that I will test tonight
    Think I got the newest, i'll double check and maybe redo the profiles, thanks and i'll be eagerly awaiting your possible fix.
    I ran into your issue for the first time today. I didn't have time to test my change so I will try again tonight.
  5. Droid Ninja
    bodean's Avatar
    Member #
    1033
    Join Date
    Nov 2009
    Location
    Chicago, IL
    Posts
    1,155
    Liked
    3 times
    Phone
    Droid X (Rooted), Iphone 4 JB.
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by Tallica View Post
    Ok I think it's working correctly. When I'm home my connected, home, a wifi on profiles are on. When I'm away from my cell near sites I have no active profiles, and when I'm near my cell sites but not connected to my Wifi I have the home profile on and it looks like it scans but shuts off if it's not in range of my router (haven't really tesed this too much yet). This seems right, correct me If something isn't.

    Now it just seems that my Wifi off profile is never active, please let me know if this is how it should be.
    It should only activate when you lose your connection to your router for 30 seconds and then should disable itself again.
    My Wifi Off always has a red X in the list in tasker. Not sure if that is normal or not. Everything else has a green checkmark
  6. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Quote Originally Posted by bodean View Post
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by Tallica View Post
    Ok I think it's working correctly. When I'm home my connected, home, a wifi on profiles are on. When I'm away from my cell near sites I have no active profiles, and when I'm near my cell sites but not connected to my Wifi I have the home profile on and it looks like it scans but shuts off if it's not in range of my router (haven't really tesed this too much yet). This seems right, correct me If something isn't.

    Now it just seems that my Wifi off profile is never active, please let me know if this is how it should be.
    It should only activate when you lose your connection to your router for 30 seconds and then should disable itself again.
    My Wifi Off always has a red X in the list in tasker. Not sure if that is normal or not. Everything else has a green checkmark
    That is normal, unless it is deactivating your wifi.
  7. Droid Ninja
    bodean's Avatar
    Member #
    1033
    Join Date
    Nov 2009
    Location
    Chicago, IL
    Posts
    1,155
    Liked
    3 times
    Phone
    Droid X (Rooted), Iphone 4 JB.
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by bodean View Post
    Quote Originally Posted by NebulaOcton View Post

    Do you want the sound to stop when you clear the notification?
    Yes. I am on call daily for work, and when they call, I need to call them back in 20 minutes. But if my phone is on ring, and I dont hear it, I never know to go look to see if I have a missed call.
    Here you go
    New - Name it "Missed Call" - Ok - Event - Phone - Missed Call - Done
    New Task - ok - "+" - Variable - Variable Set - %MCCLEAR to 0 - Done
    "+" - Media - Music Play - Pick your sound - Done
    "+" - Tasker - Wait - 2 minutes - Done
    "+" - Tasker - Stop - If %MCCLEAR matches 1 - Done
    "+" - Tasker - Goto Action - 2 - Done - Done

    New - Name it "Missed Call Clear" - Ok - Application - Contacts - Done
    New Task - Ok - "+" - Variable - Variable Set - %MCCLEAR to 1 - Done - Done - Apply
    Thanks. Will let you know how it works!
  8. Droid Newbie
    theSC00BZ's Avatar
    Member #
    146288
    Join Date
    Dec 2010
    Posts
    1
    Phone
    HTC Desire
    I created this for myself. When I put the phone on my desk, shelf, etc. the phone won't vibrate. When I put it in my pocket however, it will.

    Task: PhoneFlat0
    -----------------
    Variable|Variable Clear|%PHONEFLAT

    Task: PhoneFlat1
    -----------------
    Variable|Variable Set|%PHONEFLAT To 1|Do Maths

    Task: VibrateOn
    -----------------
    Audio|Vibrate On Ringer|On
    Audio|Vibrate On Notify|On

    Task: VibrateOff
    -----------------
    Audio|Vibrate On Ringer|Off
    Audio|Vibrate On Notify|Off


    Profile: PhoneNotFlat
    ----------------------
    Context: State|Not Orientation Face Up|Invert
    Context: State|Not Orientation Face Down|Invert
    EnterTask: PhoneFlat0
    ExitTask: PhoneFlat1

    Profile: Vibrate
    ----------------------
    Context: State|Variable Value|%PHONEFLAT|Maths:Equals|0
    EnterTask: VibrateOn
    ExitTask: VibrateOff


    Important: Assign a higher priority to the profile PhoneNotFlat to make sure this is determined before the Vibration is set.

    Of course you may make a few tweaks. For example, I use PhoneNotFlat for other things too, so maybe you don't need the "Do Maths". You also might not need the exit tasks; I just put them in to cover myself.
    Last edited by theSC00BZ; 12-09-2010 at 05:58 AM.
  9. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Quote Originally Posted by Tallica View Post
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by Tallica View Post
    Ok Neb, something is up. When I leave my house and my phone disconnects from my network, My Wifi will not turn off unless I do it manually or I leave my "home" area. If i'm connected to cell sites near my house but not close enough to connect to my router I have to shut wifi off manually. After that it seems to work right (turn on screen, wifi scans then turns off when it doesn't connect). What do you think the issue is? I think it might be that the wifi on profile is not going to it's exit task when I'm not near my wifi.
    Make sure you have the latest incarnation of the profile thats on the wiki with the exit task on the wifi near profile.

    If you do then I don't know but I have an idea on how to fix it that I will test tonight
    Think I got the newest, i'll double check and maybe redo the profiles, thanks and i'll be eagerly awaiting your possible fix.
    Ok I didn't have an issue this morning with WIFI staying on. This is going to seem a bit ridiculous...

    On you Wifi Off profile:
    Wait 1 minute until %WIFIC~0
    Wifi Off
    Profile Status Home to off
    Profile Status Wifi Near Home to off (this is the label I use yours might be different)
    Variable set %HOME to 0
    Wifi Off (yes again)
    Wait 10 seconds
    Profile Status Home to On
    Profile Status Wifi Near Home to On

    Profile Statis Wifi Off to Off

    The bold is new. If you need help programming this let me know. I want to run it for a few days to ensure it works before I update the wiki.
  10. Rescue Squad
    Tallica's Avatar
    Member #
    48266
    Join Date
    Mar 2010
    Location
    Middleboro, MA
    Posts
    3,259
    Liked
    6 times
    Twitter
    Tallica21
    Phone
    GSIII-Rooted
    Premium Member
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by Tallica View Post
    Quote Originally Posted by NebulaOcton View Post

    Make sure you have the latest incarnation of the profile thats on the wiki with the exit task on the wifi near profile.

    If you do then I don't know but I have an idea on how to fix it that I will test tonight
    Think I got the newest, i'll double check and maybe redo the profiles, thanks and i'll be eagerly awaiting your possible fix.
    Ok I didn't have an issue this morning with WIFI staying on. This is going to seem a bit ridiculous...

    On you Wifi Off profile:
    Wait 1 minute until %WIFIC~0
    Wifi Off
    Profile Status Home to off
    Profile Status Wifi Near Home to off (this is the label I use yours might be different)
    Variable set %HOME to 0
    Wifi Off (yes again)
    Wait 10 seconds
    Profile Status Home to On
    Profile Status Wifi Near Home to On

    Profile Statis Wifi Off to Off

    The bold is new. If you need help programming this let me know. I want to run it for a few days to ensure it works before I update the wiki.
    It looks like more then just the bold is new your last wifi off had a wait of 30 seconds.

    If you could type out the steps for this like the Wiki, I'd appreciate it. If it's just changing the Wifi off profile I'll delete it and make a new one.

    Sorry, this app is just confusing to me.
Page 51 of 108 FirstFirst ... 41495051525361101 ... LastLast

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Android Application Tasker
    By RW-1 in forum Android Applications
    Replies: 27
    Last Post: 12-27-2010, 12:02 PM
  2. How to set up Tasker
    By Tbone9191 in forum Android Tech Support
    Replies: 4
    Last Post: 11-22-2010, 08:39 AM
  3. Locale/Tasker using calendar?
    By harrellj in forum Android Applications
    Replies: 4
    Last Post: 08-06-2010, 05:39 PM
  4. Using Tasker + Good Morning as an ultimate personal assistant
    By jamsesh in forum Android General Discussions
    Replies: 1
    Last Post: 07-30-2010, 01:00 PM

Search tags for this page

android tasker examples

,
android tasker profiles
,

best tasker profiles

,
how to use tasker
,
tasker android examples
,

tasker examples

,
tasker forums
,

tasker profiles

,
tasker scenes
,
what have you done with tasker
Click on a term to search our site for related topics.

Tags for this Thread

Find us on Google+