DroidForums.net is the original Verizon Android Forum! Registered Users do not see these ads. Please Register - It's Free!
Page 33 of 108 FirstFirst ... 23 31 32 33 34 35 43 83 ... LastLast
Results 321 to 330 of 1072
Like Tree3Likes

Thread: What have YOU done with Tasker?

  1. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Quote Originally Posted by ViciousCircle View Post
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by bodean View Post
    How do you guys set up locations? Do you use the NET option, or another option? Trying to define my apartment location as home.
    I wrote this for enabling wifi when I get home.

    Low Battery Usage Wifi Enableing Profile Using Wifi Near - Tasker Wiki

    I've got this setup and it is working great when I am near home. Here's the weird thing...

    Usually when I am at work, I'll turn wifi on since we have an AP there. But, when I turn wifi on, it turns on, connects to the AP and gets an IP address, then says connected. Then, it turns wifi right back off. The entire time this is happening, the 'wifi off' profile stays active, so I assumed that this is why wifi was getting turned back off.

    Then, I disabled the 'wifi off' profile, turned my wifi back on and it connected to my work AP and stayed on. Then I re-enabled the 'wifi off' profile, and it still stayed on and connected (which is what I expected). So, it appears that the wifi off profile is preventing a new connection. I'm guessing that this is because there is a timing setting somewhere that prevents the wifi off profile from being able to detect that there is now a connection.

    The other thing I've noticed is that if I turn off my screen while I'm connected to an AP (not the one specified in my home area), when I turn the screen back on, the 'wifi off' profile is once again active and the wifi doesn't reconnect. I'm sure this is due to the fact that I have wifi set to not be active when the screen is off in the advanced wifi settings on the phone.

    I did just think of something that may work though while typing all of this and I'm going to try it. If it works, I'll update the post with the results.
    Weird...

    The part about the screen off is what you think it is.

    As for the other thing I am not sure. I am going to a bar this afternoon with a wifi ap and will try it out but I don't remember seeing this. You idea of a timeout somewhere is what I am thinking but I will have to look. Have you noticed either of the other two profiles getting enabled at work?

    One thing you can do is to specify the MAC address you want the WIFI Off profile to check. This way it only works when you leave the coverage of that specific AP.

    Since my home router is all I connect to that isn't on a specific time basis (like when I am in class) I added a variable state to check %HOME is cleared and I clear it when the WIFI Near profile exits. I do this because I have a large house and my bedroom doesn't get great coverage from my router. (pretty much the farthest point away from the router before you enter the attic). You could set up 2 new profiles to scan for you work router and change your WIFI Off profile to ensure a variable set in either profile is cleared before it turns off WIFI.

    That sounds confusing the way I wrote it, if you need clarification I can rewrite it.
  2. Android Addict
    ViciousCircle's Avatar
    Member #
    8121
    Join Date
    Nov 2009
    Posts
    570
    Phone
    Motorola Dröid
    Premium Member
    Quote Originally Posted by NebulaOcton View Post
    Quote Originally Posted by ViciousCircle View Post
    Quote Originally Posted by NebulaOcton View Post

    I wrote this for enabling wifi when I get home.

    Low Battery Usage Wifi Enableing Profile Using Wifi Near - Tasker Wiki

    I've got this setup and it is working great when I am near home. Here's the weird thing...

    Usually when I am at work, I'll turn wifi on since we have an AP there. But, when I turn wifi on, it turns on, connects to the AP and gets an IP address, then says connected. Then, it turns wifi right back off. The entire time this is happening, the 'wifi off' profile stays active, so I assumed that this is why wifi was getting turned back off.

    Then, I disabled the 'wifi off' profile, turned my wifi back on and it connected to my work AP and stayed on. Then I re-enabled the 'wifi off' profile, and it still stayed on and connected (which is what I expected). So, it appears that the wifi off profile is preventing a new connection. I'm guessing that this is because there is a timing setting somewhere that prevents the wifi off profile from being able to detect that there is now a connection.

    The other thing I've noticed is that if I turn off my screen while I'm connected to an AP (not the one specified in my home area), when I turn the screen back on, the 'wifi off' profile is once again active and the wifi doesn't reconnect. I'm sure this is due to the fact that I have wifi set to not be active when the screen is off in the advanced wifi settings on the phone.

    I did just think of something that may work though while typing all of this and I'm going to try it. If it works, I'll update the post with the results.
    Weird...

    The part about the screen off is what you think it is.

    As for the other thing I am not sure. I am going to a bar this afternoon with a wifi ap and will try it out but I don't remember seeing this. You idea of a timeout somewhere is what I am thinking but I will have to look. Have you noticed either of the other two profiles getting enabled at work?

    One thing you can do is to specify the MAC address you want the WIFI Off profile to check. This way it only works when you leave the coverage of that specific AP.

    Since my home router is all I connect to that isn't on a specific time basis (like when I am in class) I added a variable state to check %HOME is cleared and I clear it when the WIFI Near profile exits. I do this because I have a large house and my bedroom doesn't get great coverage from my router. (pretty much the farthest point away from the router before you enter the attic). You could set up 2 new profiles to scan for you work router and change your WIFI Off profile to ensure a variable set in either profile is cleared before it turns off WIFI.

    That sounds confusing the way I wrote it, if you need clarification I can rewrite it.
    I had thought about setting up new profiles for work, but since I don't always use it there, and the only place I have decent coverage is a smallish area in the building, I don't always have wifi on at work. Also, it still wouldn't fix the issue of the wifi being off if I'm anywhere else that has wifi I'd like to connect to.

    WHat I'm going to try though is to add another task to the exit task of my 'near home' profile that does the cell checking. When I exit that profile, I've added an exit task to turn off wifi (along with changing the varialble to 0). I believe that should do what I want. It'll still turn on and off wifi when coming/leaving home, but anywhere else, I should have control.

    As for your idea about using the MAC address, wouldn't that still leave me in the same boat? Wouldn't the profile be saying "if you're not connected to 00:00:00:00:xx I'm turning off wifi"?
    Last edited by ViciousCircle; 11-03-2010 at 11:05 AM.
    Follow me @ViciousCircle

    If you like what I do, feel free to buy me a beer
  3. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Quote Originally Posted by ViciousCircle View Post
    As for your idea about using the MAC address, wouldn't that still leave me in the same boat? Wouldn't the profile be saying "if you're not connected to 00:00:00:00:xx I'm turning off wifi"?
    Good point. I was just double checking my personal set up and I had my wifi off profile only apply to my home router via SSID and I know that I stay connected when I go to school for the two hours I am there. I don't think my time based wifi enabling profile for class is keeping wifi on because thats not how tasker works.

    I think what was happening is that when I left that SSID the wifi off profile would execute and that would be the end of it because clearing the %HOME variable is an event.

    I have an idea because of this in how to improve the WIFI off and I have lots of time at work today so I will explore it and let you know what I find out.
  4. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Ok I think I have it figured out.
    3 more profiles

    New Wifi Off
    Context:
    Not Wifi Connected
    Variable Value : %WIFI = 1 (this is a dynamic variable tasker updates based on wifi being enabled or not)
    Tasks:
    Variable Set: %WIFITIMER = 1
    Wait 30 Seconds
    Variable Set: %WIFIOFF = 1 If %WIFITIMER = 1
    Wait 5 Seconds
    Variable Clear: %WIFIOFF
    Profile Status - New Wifi Off - Off
    EXIT TASK
    Variable Set : %WIFITIMER = 0

    WIFI Off Event
    Context:
    Event - Variable Set: %WIFIOFF Value:1
    Task:
    Wifi Off

    Wifi On Event
    Context
    Event - Variable Set: %WIFI Value: 1
    Profile Status - New Wifi Off - On


    I can't test this till I get to the bar but give it a shot and let me know how it works. Try manually enabling wifi and see if it drops out. It has a 30 seconds timeout to get connected. I am not sure a task can exit before it is completely executed so that is what I am worried about. If you don't lose connection after a minute leave the area of the AP and see if WIFI is disabled.

    Oh and obviously disable the old wifi off.
    Last edited by NebulaOcton; 11-03-2010 at 11:57 AM.
  5. Junior Droid
    phydeaux98038's Avatar
    Member #
    129315
    Join Date
    Oct 2010
    Posts
    25
    Phone
    Moto Droid
    Quote Originally Posted by NebulaOcton View Post
    Ok I think I have it figured out.
    3 more profiles

    New Wifi Off
    Context:
    Not Wifi Connected
    Variable Value : %WIFI = 1 (this is a dynamic variable tasker updates based on wifi being enabled or not)
    Tasks:
    Variable Set: %WIFITIMER = 1
    Wait 30 Seconds
    Variable Set: %WIFIOFF = 1 If %WIFITIMER = 1
    Wait 5 Seconds
    Variable Clear: %WIFIOFF
    Profile Status - New Wifi Off - Off
    EXIT TASK
    Variable Set : %WIFITIMER = 0

    WIFI Off Event
    Context:
    Event - Variable Set: %WIFIOFF Value:1
    Task:
    Wifi Off

    Wifi On Event
    Context
    Event - Variable Set: %WIFI Value: 1
    Profile Status - New Wifi Off - On


    I can't test this till I get to the bar but give it a shot and let me know how it works. Try manually enabling wifi and see if it drops out. It has a 30 seconds timeout to get connected. I am not sure a task can exit before it is completely executed so that is what I am worried about. If you don't lose connection after a minute leave the area of the AP and see if WIFI is disabled.

    Oh and obviously disable the old wifi off.
    If I can ever get off this conference call, I'll give this a try.
  6. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Don't bother. I tried it and am experimenting still. I am stuck in a loop and don't know why. I'll write the derails up in about 45 minutes when% get home.

    Sent from my Droid using DroidForums App
  7. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Ok so I have disabled the two event profiles. I also removed anything with %wifioff and just put in wifi off if %wifitimer matches 1 I then deleted the profile status at the end of the enter task. Then I found out %wifi uses words not numbers so I had to change the 1 to on.

    Now when turn on wifi the profile starts. If I connect, everything if fine. If not but there is a router nearby, it shuts off wifi like it's supposed to but the some how wifi is enabled again and I get in a loop.

    Sent from my Droid using DroidForums App
  8. Android Addict
    ViciousCircle's Avatar
    Member #
    8121
    Join Date
    Nov 2009
    Posts
    570
    Phone
    Motorola Dröid
    Premium Member
    Haven't had time to play with this yet, but I'm thinking an Event Profile/Task will do what I want as far as setting wifi off. I'm thinking that setting a variable when the wifi connection is dropped, then setting an event to look for that variable set event will allow me to turn off wifi. Since an event profile/task doesn't have a duration (it just executes then is done), that 'should' be workable. Other types of profiles persist while a condition is true, but according to the tasker user guide, events basically fire, then are done.
    Follow me @ViciousCircle

    If you like what I do, feel free to buy me a beer
  9. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Quote Originally Posted by ViciousCircle View Post
    Haven't had time to play with this yet, but I'm thinking an Event Profile/Task will do what I want as far as setting wifi off. I'm thinking that setting a variable when the wifi connection is dropped, then setting an event to look for that variable set event will allow me to turn off wifi. Since an event profile/task doesn't have a duration (it just executes then is done), that 'should' be workable. Other types of profiles persist while a condition is true, but according to the tasker user guide, events basically fire, then are done.
    That was my thinking in what I wrote up, but I don't understand why wifi keeps getting reenabled. I also wanted to stop it from turning wifi off if for some reason there was just a little hiccup in the signal, that why I put in the 30 second delay.

    Looks like my day will be pretty light again so I will see what I can do.
  10. Master Droid
    NebulaOcton's Avatar
    Member #
    80961
    Join Date
    Jun 2010
    Posts
    329
    Liked
    1 times
    Phone
    Motorola Droid
    Ok This seems to work all of a sudden
    Let me know if you run into trouble.


    New Wifi Off
    Context:
    Not Wifi Connected
    Variable Value : %WIFI matches on (this is a dynamic variable tasker
    updates based on wifi being enabled or not)
    Tasks:
    Variable Set: %WIFITIMER to 1
    Wait 30 Seconds
    Variable Set: %WIFIOFF to 1 If %WIFITIMER matches 1
    Wait 5 Seconds
    Variable Clear: %WIFIOFF
    Profile Status - New Wifi Off - Off
    EXIT TASK
    Variable Set : %WIFITIMER to 0
    WIFI Off Event
    Context:
    Event - Variable Set: %WIFIOFF Value:1
    Task:
    Wifi Off
    Wifi On Event
    Context
    Event - Variable Set: %WIFI Value: on
    Profile Status - New Wifi Off - On
Page 33 of 108 FirstFirst ... 23 31 32 33 34 35 43 83 ... LastLast

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Android Application Tasker
    By RW-1 in forum Android Applications
    Replies: 27
    Last Post: 12-27-2010, 12:02 PM
  2. How to set up Tasker
    By Tbone9191 in forum Android Tech Support
    Replies: 4
    Last Post: 11-22-2010, 08:39 AM
  3. Locale/Tasker using calendar?
    By harrellj in forum Android Applications
    Replies: 4
    Last Post: 08-06-2010, 05:39 PM
  4. Using Tasker + Good Morning as an ultimate personal assistant
    By jamsesh in forum Android General Discussions
    Replies: 1
    Last Post: 07-30-2010, 01:00 PM

Search tags for this page

android tasker examples

,
android tasker profiles
,

best tasker profiles

,
how to use tasker
,
tasker android examples
,

tasker examples

,
tasker forums
,

tasker profiles

,
tasker scenes
,
what have you done with tasker
Click on a term to search our site for related topics.

Tags for this Thread

Find us on Google+