Can someone help me with this. I have it set to Google calendar and to sync every 5 minutes. I am using a Thunderbolt. If I go to settings>Accounts & Sync I checked off Background data & Auto-Sync. If I tap Google it syncs but not automatically.

Thanks