Since the last update of PowerAMP added the official Apps2SD support, having reliable widget support was no longer possible (I am fairly sure that this is an Android problem in general that Google should really address). Solution? This widget pack, which is installed separately.

PowerAMP Standard Widget PackStandard PowerAMP Widgets.
Should be used for PowerAMP installed on SD card.
Work with PowerAMP v1.3 and above.